aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am8
-rw-r--r--configure.ac11
-rw-r--r--tests/Makefile.am11
3 files changed, 4 insertions, 26 deletions
diff --git a/Makefile.am b/Makefile.am
index b589e72e7..7950980c0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -90,15 +90,9 @@ else
doc =
endif
-if RUN_TESTS
-tests = tests
-else
-tests =
-endif
-
SUBDIRS = m4 common kbx \
${gpg} ${sm} ${agent} ${scd} ${g13} ${dirmngr} \
- ${tools} po ${doc} ${tests}
+ ${tools} po ${doc} tests
dist_doc_DATA = README
diff --git a/configure.ac b/configure.ac
index 85cd69a79..9c591ed6a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -626,7 +626,6 @@ have_dosish_system=no
have_w32_system=no
have_w32ce_system=no
have_android_system=no
-run_tests=yes
use_simple_gettext=no
use_ldapwrapper=yes
mmap_needed=yes
@@ -643,7 +642,6 @@ case "${host}" in
have_dosish_system=yes
have_w32_system=yes
require_iconv=no
- run_tests=no
use_ldapwrapper=no # Fixme: Do this only for CE.
case "${host}" in
*-mingw32ce*)
@@ -702,7 +700,6 @@ case "${host}" in
# Android is fully utf-8 and we do not want to use iconv to
# keeps things simple
require_iconv=no
- run_tests=no
;;
*)
;;
@@ -733,11 +730,6 @@ if test "$have_android_system" = yes; then
fi
AM_CONDITIONAL(HAVE_ANDROID_SYSTEM, test "$have_android_system" = yes)
-if test "$run_tests" = yes; then
- AC_DEFINE(RUN_TESTS,1, [Defined if we should run the tests])
-fi
-AM_CONDITIONAL(RUN_TESTS, test "$run_tests" = yes)
-
# (These need to go after AC_PROG_CC so that $EXEEXT is defined)
AC_DEFINE_UNQUOTED(EXEEXT,"$EXEEXT",[The executable file extension, if any])
@@ -1693,9 +1685,6 @@ AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes)
AM_CONDITIONAL(NO_TRUST_MODELS, test "$use_trust_models" = no)
AM_CONDITIONAL(USE_TOFU, test "$use_tofu" = yes)
-AM_CONDITIONAL(RUN_GPG_TESTS,
- test x$cross_compiling = xno -a "$build_gpg" = yes )
-
#
# Set some defines for use gpgconf.
#
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d72f51e8b..6ede0d409 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,14 +18,7 @@
## Process this file with automake to produce Makefile.in
-
-if RUN_GPG_TESTS
-openpgp = openpgp
-else
-openpgp =
-endif
-
-SUBDIRS = gpgscm ${openpgp} . migrations pkits
+SUBDIRS = gpgscm openpgp migrations pkits .
GPGSM = ../sm/gpgsm
@@ -66,7 +59,9 @@ CLEANFILES = inittests.stamp x y y z out err \
DISTCLEANFILES = pubring.kbx~ random_seed
+if !HAVE_W32_SYSTEM
noinst_PROGRAMS = asschk
+endif
asschk_SOURCES = asschk.c