aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog5
-rw-r--r--configure.ac4
2 files changed, 7 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 000f1665d..77333f162 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2002-09-19 David Shaw <[email protected]>
+
+ * configure.ac: Try linking LDAP as just -lldap as it seems very
+ recent OpenLDAPs (>=2.0.23) support that.
+
2002-09-14 David Shaw <[email protected]>
* configure.ac: Try linking LDAP without -lresolv first, just in
diff --git a/configure.ac b/configure.ac
index bdb785452..26e5250a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -355,11 +355,11 @@ AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt,
[NETLIBS="-lsocket $NETLIBS"]))
# Try and link a LDAP test program to weed out unusable LDAP
-# libraries. -lldap -llber [-lresolv] is for OpenLDAP. -lldapssl41
+# libraries. -lldap [-llber [-lresolv]] is for OpenLDAP. -lldapssl41
# is for Mozilla LDAP.
if test "$try_ldap" = yes ; then
- for LDAPLIBS in "-lldap -llber" "-lldap -llber -lresolv" "-lldapssl41"; do
+ for LDAPLIBS in "-lldap" "-lldap -llber" "-lldap -llber -lresolv" "-lldapssl41"; do
_ldap_save_libs=$LIBS
LIBS="$LDAPLIBS $NETLIBS $LIBS"