aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--agent/ChangeLog5
-rw-r--r--agent/gpg-agent.c4
-rw-r--r--common/Makefile.am1
3 files changed, 9 insertions, 1 deletions
diff --git a/agent/ChangeLog b/agent/ChangeLog
index bb9c9b0e3..894bb5854 100644
--- a/agent/ChangeLog
+++ b/agent/ChangeLog
@@ -1,3 +1,8 @@
+2003-07-04 Werner Koch <[email protected]>
+
+ * gpg-agent.c (handle_connections): Kludge to allow use of Pth 1
+ and 2.
+
2003-06-30 Werner Koch <[email protected]>
* call-scd.c (learn_status_cb): Store the serialno in PARM.
diff --git a/agent/gpg-agent.c b/agent/gpg-agent.c
index b8c69fb56..675f2be3f 100644
--- a/agent/gpg-agent.c
+++ b/agent/gpg-agent.c
@@ -1034,7 +1034,11 @@ handle_connections (int listen_fd)
fd = pth_accept_ev (listen_fd, (struct sockaddr *)&paddr, &plen, ev);
if (fd == -1)
{
+#ifdef PTH_STATUS_OCCURRED /* This is Pth 2 */
if (pth_event_status (ev) == PTH_STATUS_OCCURRED)
+#else
+ if (pth_event_occurred (ev))
+#endif
{
handle_signal (signo);
continue;
diff --git a/common/Makefile.am b/common/Makefile.am
index 11dc79ae1..d6e7d4d49 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -21,7 +21,6 @@
EXTRA_DIST = mkerrors mkerrtok
#INCLUDES =
-BUILT_SOURCES = errors.c
noinst_LIBRARIES = libcommon.a