aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--ChangeLog8
-rw-r--r--NEWS16
-rw-r--r--configure.ac11
3 files changed, 18 insertions, 17 deletions
diff --git a/ChangeLog b/ChangeLog
index 020e1663d..0cdcb885f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2005-10-14 David Shaw <[email protected]>
+
+ * NEWS: Clarify the cURL keyserver changes, and add a note about
+ gpg-zip.
+
+ * configure.ac: Remove the backsig configure options since this is
+ all done at runtime now.
+
2005-10-11 David Shaw <[email protected]>
* configure.ac: Did some backsig testing with the PGP folks. All
diff --git a/NEWS b/NEWS
index ac6a483d2..9fe4ca9b9 100644
--- a/NEWS
+++ b/NEWS
@@ -2,13 +2,14 @@ Noteworthy changes in version 1.4.3
------------------------------------------------
* If available, cURL-based keyserver helpers are built that can
- retrieve keys using any protocol that cURL supports. This
- includes HKP as well as all protocols that cURL can handle
+ retrieve keys using HKP or any protocol that cURL supports
(HTTP, HTTPS, FTP, FTPS, etc). If cURL is not available, HKP
- and HTTP are still supported using the included code. To force
- building the old keyserver helpers, use the configure option
- --enable-old-keyserver-helpers. Note that none of this affects
- finger or LDAP support, which are unchanged.
+ and HTTP are still supported using a built-in cURL emulator. To
+ force building the old pre-cURL keyserver helpers, use the
+ configure option --enable-old-keyserver-helpers. Note that none
+ of this affects finger or LDAP support, which are unchanged.
+ Note also that a future version of GnuPG will remove the old
+ keyserver helpers altogether.
* Implemented Public Key Association (PKA) trust model option.
This is an optional trust model on top of the standard ones. It
@@ -16,6 +17,9 @@ Noteworthy changes in version 1.4.3
associate a mail address with an OpenPGP key. See: XXXX for a
description.
+ * Added "gpg-zip", a program to create encrypted archives that can
+ interoperate with PGP Zip.
+
Noteworthy changes in version 1.4.2 (2005-07-26)
------------------------------------------------
diff --git a/configure.ac b/configure.ac
index d77d4eaca..d04ddf677 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,13 +129,6 @@ AC_ARG_ENABLE(gnupg-iconv,
gnupg_use_iconv=$enableval, gnupg_use_iconv=yes)
AC_MSG_RESULT($gnupg_use_iconv)
-AC_MSG_CHECKING([whether to require signing subkeys to have back signatures])
-AC_ARG_ENABLE(backsigs,
- AC_HELP_STRING([--enable-backsigs],
- [require signing subkeys to have back signatures]),
- do_backsigs=$enableval, do_backsigs=no)
-AC_MSG_RESULT($do_backsigs)
-
dnl See if we are disabling any algorithms or features for a smaller
dnl binary
@@ -757,10 +750,6 @@ if test "$gnupg_use_iconv" = yes ; then
AC_DEFINE(USE_GNUPG_ICONV,1,[Define to use the new iconv based code])
fi
-if test "$do_backsigs" = no ; then
- AC_DEFINE(FAKE_BACKSIGS,1,[Define to fake missing backsigs])
-fi
-
AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes)
AM_CONDITIONAL(ENABLE_AGENT_SUPPORT, test "$agent_support" = yes)