diff options
Diffstat (limited to '')
-rw-r--r-- | ChangeLog | 5 | ||||
-rw-r--r-- | configure.ac | 16 |
2 files changed, 20 insertions, 1 deletions
@@ -1,3 +1,8 @@ +2005-06-13 David Shaw <[email protected]> + + * configure.ac: Add check for no-pointer-sign warning keyword, and + disable. This is gcc4 specific. + 2005-05-31 Werner Koch <[email protected]> Released 1.4.2rc1. diff --git a/configure.ac b/configure.ac index c4123cf30..950fa0745 100644 --- a/configure.ac +++ b/configure.ac @@ -1214,7 +1214,7 @@ esac AC_SUBST(NETLIBS) AC_SUBST(W32LIBS) -# Special options used fith gcc. +# Special options used with gcc. if test "$GCC" = yes; then # Note that it is okay to use CFLAGS here because this are just # warning options and the user should have a chance of overriding @@ -1226,6 +1226,20 @@ if test "$GCC" = yes; then CFLAGS="$CFLAGS -Wall" fi + AC_MSG_CHECKING([if gcc supports -Wno-pointer-sign]) + + _gcc_cflags_save=$CFLAGS + CFLAGS="-Wno-pointer-sign" + + AC_COMPILE_IFELSE(AC_LANG_PROGRAM([]),_gcc_psign=yes,_gcc_psign=no) + AC_MSG_RESULT($_gcc_psign) + + CFLAGS=$_gcc_cflags_save; + + if test x"$_gcc_psign" = xyes ; then + CFLAGS="$CFLAGS -Wno-pointer-sign" + fi + # Non exec stack hack. Fixme: Write a test to check whether as # can cope with it and use the enable-noexecstack option only to # disable it in case it is required on sime platforms. |