aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--AUTHORS2
-rw-r--r--THANKS1
-rw-r--r--agent/gpg-agent.c7
-rw-r--r--agent/preset-passphrase.c4
-rw-r--r--agent/protect-tool.c4
-rw-r--r--configure.ac2
-rw-r--r--g10/gpg.c4
-rw-r--r--g10/gpgv.c4
-rw-r--r--kbx/kbxutil.c5
-rw-r--r--scd/ChangeLog10
-rw-r--r--scd/apdu.c1
-rw-r--r--scd/ccid-driver.c39
-rw-r--r--scd/sc-copykeys.c4
-rw-r--r--scd/scdaemon.c4
-rw-r--r--sm/gpgsm.c4
-rw-r--r--tools/gpg-check-pattern.c4
-rw-r--r--tools/gpg-connect-agent.c4
-rw-r--r--tools/gpgconf.c4
-rw-r--r--tools/gpgsplit.c5
-rw-r--r--tools/symcryptrun.c4
20 files changed, 75 insertions, 41 deletions
diff --git a/AUTHORS b/AUTHORS
index 54d6eb03e..de123ab78 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -1,7 +1,7 @@
Program: GnuPG
Homepage: http://www.gnupg.org
Maintainer: Werner Koch <[email protected]>
-Bug reports: <[email protected]>
+Bug reports: http://bugs.gnupg.org
Security related bug reports: <[email protected]>
License: GPLv3+
diff --git a/THANKS b/THANKS
index 589ab257a..8e4c9129a 100644
--- a/THANKS
+++ b/THANKS
@@ -118,6 +118,7 @@ Jeffery Von Ronne jronne at ics.uci.edu
Jens Bachem bachem at rrz.uni-koeln.de
Jens Seidel jensseidel at users.sf.net
Jeroen C. van Gelderen jeroen at vangelderen.org
+Jeroen Schot schot at a-eskwadraat nl
J Horacio MG homega at ciberia.es
J. Michael Ashley jashley at acm.org
Jim Bauer jfbauer at home.com
diff --git a/agent/gpg-agent.c b/agent/gpg-agent.c
index 31d79d508..2e8156721 100644
--- a/agent/gpg-agent.c
+++ b/agent/gpg-agent.c
@@ -326,8 +326,11 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ /* TRANSLATORS: @EMAIL@ will get replaced by the actual bug
+ reporting address. This is so that we can change the
+ reporting address without breaking the translations. */
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 20:
if (!ver_gcry)
ver_gcry = make_libversion ("libgcrypt", gcry_check_version);
diff --git a/agent/preset-passphrase.c b/agent/preset-passphrase.c
index 77646d87e..8e3b3e2c5 100644
--- a/agent/preset-passphrase.c
+++ b/agent/preset-passphrase.c
@@ -91,8 +91,8 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40:
p = _("Usage: gpg-preset-passphrase [options] KEYGRIP (-h for help)\n");
diff --git a/agent/protect-tool.c b/agent/protect-tool.c
index 27f4f9d0a..78234d22d 100644
--- a/agent/protect-tool.c
+++ b/agent/protect-tool.c
@@ -157,8 +157,8 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p = _("Usage: gpg-protect-tool [options] (-h for help)\n");
break;
diff --git a/configure.ac b/configure.ac
index bc7ba2095..a52f22d80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ m4_define([svn_revision], m4_esyscmd([printf "%d" $(svn info 2>/dev/null \
| sed -n '/^Revision:/ s/[^0-9]//gp'|head -1)]))
AC_INIT([gnupg],
[my_version[]m4_if(my_issvn,[yes],[-svn[]svn_revision])],
+ [http://bugs.gnupg.org])
# Set development_version to yes if the minor number is odd or you
# feel that the default check for a development version is not
# sufficient.
diff --git a/g10/gpg.c b/g10/gpg.c
index d7ac01971..2f9acb63d 100644
--- a/g10/gpg.c
+++ b/g10/gpg.c
@@ -804,9 +804,7 @@ my_strusage( int level )
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p =
- _("Please report bugs to <[email protected]>.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
case 20:
if (!ver_gcry)
diff --git a/g10/gpgv.c b/g10/gpgv.c
index 2797139e3..e1f20fb7d 100644
--- a/g10/gpgv.c
+++ b/g10/gpgv.c
@@ -111,8 +111,8 @@ my_strusage( int level )
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <[email protected]>.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p = _("Usage: gpgv [options] [files] (-h for help)");
break;
diff --git a/kbx/kbxutil.c b/kbx/kbxutil.c
index efb2eff7e..459281110 100644
--- a/kbx/kbxutil.c
+++ b/kbx/kbxutil.c
@@ -110,9 +110,8 @@ my_strusage( int level )
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p =
- _("Please report bugs to " PACKAGE_BUGREPORT ".\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p =
_("Usage: kbxutil [options] [files] (-h for help)");
diff --git a/scd/ChangeLog b/scd/ChangeLog
index 46b15f0c7..59487fe17 100644
--- a/scd/ChangeLog
+++ b/scd/ChangeLog
@@ -1,3 +1,13 @@
+2009-07-21 Werner Koch <[email protected]>
+
+ * ccid-driver.c [HAVE_PTH]: Include pth.h.
+ (my_sleep): New.
+ (bulk_in): s/gnupg_sleep/my_sleep/.
+
+2009-07-20 Werner Koch <[email protected]>
+
+ * apdu.c [GNUPG_MAJOR_VERSION==1]: Include dynload.h.
+
2009-07-16 Werner Koch <[email protected]>
* command.c (update_reader_status_file): Test for unplugged reader.
diff --git a/scd/apdu.c b/scd/apdu.c
index 36bae89c0..d114b6eca 100644
--- a/scd/apdu.c
+++ b/scd/apdu.c
@@ -54,6 +54,7 @@
#include "memory.h"
#include "util.h"
#include "i18n.h"
+#include "dynload.h"
#include "cardglue.h"
#else /* GNUPG_MAJOR_VERSION != 1 */
#include "scdaemon.h"
diff --git a/scd/ccid-driver.c b/scd/ccid-driver.c
index 373f55f8a..b71c43c29 100644
--- a/scd/ccid-driver.c
+++ b/scd/ccid-driver.c
@@ -85,6 +85,9 @@
#include <sys/stat.h>
#include <fcntl.h>
#include <time.h>
+#ifdef HAVE_PTH
+# include <pth.h>
+#endif /*HAVE_PTH*/
#include <usb.h>
@@ -312,6 +315,30 @@ set_msg_len (unsigned char *msg, unsigned int length)
static void
+my_sleep (int seconds)
+{
+#ifdef HAVE_PTH
+ /* With Pth we also call the standard sleep(0) so that the process
+ may give up its timeslot. */
+ if (!seconds)
+ {
+# ifdef HAVE_W32_SYSTEM
+ Sleep (0);
+# else
+ sleep (0);
+# endif
+ }
+ pth_sleep (seconds);
+#else
+# ifdef HAVE_W32_SYSTEM
+ Sleep (seconds*1000);
+# else
+ sleep (seconds);
+# endif
+#endif
+}
+
+static void
print_progress (ccid_driver_t handle)
{
time_t ct = time (NULL);
@@ -1766,8 +1793,8 @@ bulk_out (ccid_driver_t handle, unsigned char *msg, size_t msglen,
{
int rc;
- /* No need to continue and clutter the log withy USB error if we
- ever got an ENODEV. */
+ /* No need to continue and clutter the log with USB write error
+ messages after we got the first ENODEV. */
if (handle->enodev_seen)
return CCID_DRIVER_ERR_NO_READER;
@@ -1900,9 +1927,7 @@ bulk_in (ccid_driver_t handle, unsigned char *buffer, size_t length,
DEBUGOUT_1 ("usb_bulk_read error: %s\n", strerror (rc));
if (rc == EAGAIN && eagain_retries++ < 3)
{
-#ifndef TEST
- gnupg_sleep (1);
-#endif
+ my_sleep (1);
goto retry;
}
return CCID_DRIVER_ERR_CARD_IO_ERROR;
@@ -1919,9 +1944,7 @@ bulk_in (ccid_driver_t handle, unsigned char *buffer, size_t length,
handle->dev_fd, strerror (rc));
if (rc == EAGAIN && eagain_retries++ < 5)
{
-#ifndef TEST
- gnupg_sleep (1);
-#endif
+ my_sleep (1);
goto retry;
}
return CCID_DRIVER_ERR_CARD_IO_ERROR;
diff --git a/scd/sc-copykeys.c b/scd/sc-copykeys.c
index 275bcf877..615e4b28a 100644
--- a/scd/sc-copykeys.c
+++ b/scd/sc-copykeys.c
@@ -76,8 +76,8 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p = _("Usage: sc-copykeys [options] (-h for help)\n");
break;
diff --git a/scd/scdaemon.c b/scd/scdaemon.c
index 24cb346e6..175729a03 100644
--- a/scd/scdaemon.c
+++ b/scd/scdaemon.c
@@ -242,8 +242,8 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 20:
if (!ver_gcry)
ver_gcry = make_libversion ("libgcrypt", gcry_check_version);
diff --git a/sm/gpgsm.c b/sm/gpgsm.c
index b5f18d767..93e907658 100644
--- a/sm/gpgsm.c
+++ b/sm/gpgsm.c
@@ -509,8 +509,8 @@ my_strusage( int level )
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p = _("Usage: gpgsm [options] [files] (-h for help)");
break;
diff --git a/tools/gpg-check-pattern.c b/tools/gpg-check-pattern.c
index b29687d37..8d152631d 100644
--- a/tools/gpg-check-pattern.c
+++ b/tools/gpg-check-pattern.c
@@ -138,8 +138,8 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40:
p = _("Usage: gpg-check-pattern [options] patternfile (-h for help)\n");
diff --git a/tools/gpg-connect-agent.c b/tools/gpg-connect-agent.c
index 2bea98d8d..ac75c3b0e 100644
--- a/tools/gpg-connect-agent.c
+++ b/tools/gpg-connect-agent.c
@@ -177,8 +177,8 @@ my_strusage( int level )
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p = _("Usage: gpg-connect-agent [options] (-h for help)");
break;
diff --git a/tools/gpgconf.c b/tools/gpgconf.c
index 1656a402e..76e44670a 100644
--- a/tools/gpgconf.c
+++ b/tools/gpgconf.c
@@ -99,8 +99,8 @@ my_strusage( int level )
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p = _("Usage: gpgconf [options] (-h for help)");
break;
diff --git a/tools/gpgsplit.c b/tools/gpgsplit.c
index 0d7faa061..e4872dc31 100644
--- a/tools/gpgsplit.c
+++ b/tools/gpgsplit.c
@@ -85,9 +85,8 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p =
- "Please report bugs to <[email protected]>.\n";
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p =
"Usage: gpgsplit [options] [files] (-h for help)";
diff --git a/tools/symcryptrun.c b/tools/symcryptrun.c
index 286680496..b46990cd2 100644
--- a/tools/symcryptrun.c
+++ b/tools/symcryptrun.c
@@ -201,8 +201,8 @@ my_strusage (int level)
break;
case 13: p = VERSION; break;
case 17: p = PRINTABLE_OS_NAME; break;
- case 19: p = _("Please report bugs to <" PACKAGE_BUGREPORT ">.\n");
- break;
+ case 19: p = _("Please report bugs to <@EMAIL@>.\n"); break;
+
case 1:
case 40: p = _("Usage: symcryptrun [options] (-h for help)");
break;