aboutsummaryrefslogtreecommitdiffstats
path: root/util
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-12-06 20:54:05 +0000
committerDavid Shaw <[email protected]>2005-12-06 20:54:05 +0000
commitbc1c4af8c3ce3ca4ba0ae2b01843553e415dbb51 (patch)
tree582ab2438b8763ab3779f7a98f5d94d41cf4f4b4 /util
parent* idea-stub.c (load_module): Not legal to return a void * as a function (diff)
downloadgnupg-bc1c4af8c3ce3ca4ba0ae2b01843553e415dbb51.tar.gz
gnupg-bc1c4af8c3ce3ca4ba0ae2b01843553e415dbb51.zip
Some cleanup so we don't build files that are completely ifdeffed out.
This causes a warning on Sun's cc. Do the internal regex code as well for consistency.
Diffstat (limited to 'util')
-rw-r--r--util/ChangeLog4
-rw-r--r--util/Makefile.am38
2 files changed, 26 insertions, 16 deletions
diff --git a/util/ChangeLog b/util/ChangeLog
index d69853c44..754b9d277 100644
--- a/util/ChangeLog
+++ b/util/ChangeLog
@@ -1,5 +1,9 @@
2005-12-06 David Shaw <[email protected]>
+ * Makefile.am: Some cleanup so we don't build files that are
+ completely ifdeffed out. This causes a warning on Sun's cc. Do
+ the internal regex code as well for consistency.
+
* mkdtemp.c (mkdtemp): Fix warning.
* secmem.c, assuan-buffer.c, dotlock.c: Fix a few warnings from
diff --git a/util/Makefile.am b/util/Makefile.am
index cb2019be4..8be94a90b 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -22,28 +22,35 @@ INCLUDES = -I.. -I$(top_srcdir)/include -I$(top_srcdir)/intl
noinst_LIBRARIES = libutil.a
-EXTRA_libutil_a_SOURCES = regcomp.c regex.c regexec.c regex_internal.c \
- regex_internal.h
+libutil_a_SOURCES = logger.c fileutil.c miscutil.c strgutil.c \
+ ttyio.c argparse.c memory.c secmem.c errors.c iobuf.c \
+ dotlock.c http.c srv.h srv.c pka.c membuf.c
+
+if USE_SIMPLE_GETTEXT
+libutil_a_SOURCES+=simple-gettext.c
+endif
+
+if HAVE_W32_SYSTEM
+libutil_a_SOURCES+=w32reg.c
+endif
-# We build the assuan support only if it has been requested.
if ENABLE_AGENT_SUPPORT
-assuan_source = assuan-buffer.c assuan-client.c assuan-defs.h \
- assuan-errors.c assuan-logging.c assuan-socket-connect.c \
- assuan-connect.c assuan-socket.c assuan-util.c
-else
-assuan_source =
+libutil_a_SOURCES+=assuan-buffer.c assuan-client.c assuan-defs.h \
+ assuan-errors.c assuan-logging.c assuan-socket-connect.c \
+ assuan-connect.c assuan-socket.c assuan-util.c
endif
+if USE_INTERNAL_REGEX
+libutil_a_SOURCES+=regex.c
+endif
-#libutil_a_LDFLAGS =
-libutil_a_SOURCES = logger.c fileutil.c miscutil.c strgutil.c \
- ttyio.c argparse.c memory.c secmem.c errors.c iobuf.c \
- dotlock.c http.c srv.h srv.c pka.c simple-gettext.c \
- membuf.c w32reg.c $(assuan_source)
+# The internal regex code #includes these.
+EXTRA_libutil_a_SOURCES = regcomp.c regexec.c regex_internal.c \
+ regex_internal.h
-libutil_a_DEPENDENCIES = @LIBOBJS@ @REGEX_O@
# LIBOBJS is for the replacement functions
-libutil_a_LIBADD = @LIBOBJS@ @REGEX_O@
+libutil_a_DEPENDENCIES = @LIBOBJS@
+libutil_a_LIBADD = @LIBOBJS@
http-test: http.c
cc -DHAVE_CONFIG_H -I. -I. -I.. $(INCLUDES) $(LDFLAGS) -g -Wall \
@@ -56,4 +63,3 @@ srv-test: srv.c
pka-test: pka.c
cc -DHAVE_CONFIG_H -I. -I. -I.. $(INCLUDES) $(LDFLAGS) -g -Wall \
-DTEST -o pka-test pka.c libutil.a @LIBINTL@ @SRVLIBS@ @CAPLIBS@
-