aboutsummaryrefslogtreecommitdiffstats
path: root/util/srv.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-12-16 18:36:42 +0000
committerDavid Shaw <[email protected]>2004-12-16 18:36:42 +0000
commit2b9e678fded7878928893e7b22311c84f366066b (patch)
tree8d7abcc2636ba59da7bd930141674347df675c6b /util/srv.h
parentpost release updates (diff)
downloadgnupg-2b9e678fded7878928893e7b22311c84f366066b.tar.gz
gnupg-2b9e678fded7878928893e7b22311c84f366066b.zip
* configure.ac: Check for arpa/nameser.h.
* srv.h: Don't include arpa/nameser.h unless we have it. Include "types.h" for u16.
Diffstat (limited to 'util/srv.h')
-rw-r--r--util/srv.h5
1 files changed, 4 insertions, 1 deletions
diff --git a/util/srv.h b/util/srv.h
index 903a80483..2270f6a5f 100644
--- a/util/srv.h
+++ b/util/srv.h
@@ -1,5 +1,5 @@
/* srv.h
- * Copyright (C) 2003 Free Software Foundation, Inc.
+ * Copyright (C) 2003, 2004 Free Software Foundation, Inc.
*
* This file is part of GNUPG.
*
@@ -25,9 +25,12 @@
#include <windows.h>
#else
#include <netinet/in.h>
+#ifdef HAVE_ARPA_NAMESER_H
#include <arpa/nameser.h>
+#endif
#include <resolv.h>
#endif
+#include "types.h"
#ifndef MAXDNAME
#define MAXDNAME 1025