aboutsummaryrefslogtreecommitdiffstats
path: root/util/srv.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-03-11 22:04:53 +0000
committerDavid Shaw <[email protected]>2003-03-11 22:04:53 +0000
commit81844d2b65e5b5fab28caec29d1ff6c7d680c34a (patch)
tree6888abffa75b74c2dd3877b839fd7280a49db071 /util/srv.h
parent* Makefile.am: Use @CAPLIBS@ to link in -lcap if we are using (diff)
downloadgnupg-81844d2b65e5b5fab28caec29d1ff6c7d680c34a.tar.gz
gnupg-81844d2b65e5b5fab28caec29d1ff6c7d680c34a.zip
* http.c (connect_server): Use DNS SRV to get a server list. Fail over to
A records if necessary. * Makefile.am, srv.h, srv.c: New DNS SRV handling code.
Diffstat (limited to '')
-rw-r--r--util/srv.h43
1 files changed, 43 insertions, 0 deletions
diff --git a/util/srv.h b/util/srv.h
new file mode 100644
index 000000000..518151f71
--- /dev/null
+++ b/util/srv.h
@@ -0,0 +1,43 @@
+/* srv.h
+ * Copyright (C) 2003 Free Software Foundation, Inc.
+ *
+ * This file is part of GNUPG.
+ *
+ * GNUPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GNUPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+#ifndef _SRV_H_
+#define _SRV_H_
+
+#include <netinet/in.h>
+#include <arpa/nameser.h>
+#include <resolv.h>
+
+#ifndef MAXDNAME
+#define MAXDNAME 1025
+#endif
+
+struct srventry
+{
+ uint16_t priority;
+ uint16_t weight;
+ uint16_t port;
+ int run_count;
+ char target[MAXDNAME];
+};
+
+int getsrv(const char *name,struct srventry **list);
+
+#endif /* !_SRV_H_ */