aboutsummaryrefslogtreecommitdiffstats
path: root/util/srv.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-05-31 03:15:50 +0000
committerDavid Shaw <[email protected]>2003-05-31 03:15:50 +0000
commit4d297a7ff1bcd55be2d6bb1d648b1f4ed0f355f3 (patch)
treedfd08f9bd942207ad3eb5de08bdd5fbe8b1b6fe7 /util/srv.c
parent* configure.ac: Put wsock32 in NETLIBS. Put zlib in ZLIBS. Put dl in (diff)
downloadgnupg-4d297a7ff1bcd55be2d6bb1d648b1f4ed0f355f3.tar.gz
gnupg-4d297a7ff1bcd55be2d6bb1d648b1f4ed0f355f3.zip
* srv.h, srv.c: Include windows.h with MINGW32.
Diffstat (limited to 'util/srv.c')
-rw-r--r--util/srv.c6
1 files changed, 5 insertions, 1 deletions
diff --git a/util/srv.c b/util/srv.c
index 35f5b7109..e73d3f85c 100644
--- a/util/srv.c
+++ b/util/srv.c
@@ -20,10 +20,14 @@
#include <config.h>
#ifdef USE_DNS_SRV
-#include <sys/types.h>
+#ifdef __MINGW32__
+#include <windows.h>
+#else
#include <netinet/in.h>
#include <arpa/nameser.h>
#include <resolv.h>
+#endif
+#include <sys/types.h>
#include <unistd.h>
#include <stdlib.h>
#include <string.h>