aboutsummaryrefslogtreecommitdiffstats
path: root/util/setenv.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-02-20 15:10:36 +0000
committerDavid Shaw <[email protected]>2004-02-20 15:10:36 +0000
commita3ba17e09eaf08982b0d61defe630ace67eedc53 (patch)
tree005d90a9dbf572d9b73a1a9062a442bea22b3539 /util/setenv.c
parent* mkdtemp.c: Removed. (diff)
downloadgnupg-a3ba17e09eaf08982b0d61defe630ace67eedc53.tar.gz
gnupg-a3ba17e09eaf08982b0d61defe630ace67eedc53.zip
* mkdtemp.c: New (moved from g10/), setenv.c: New, unsetenv.c: New.
* Makefile.am: Include @LIBOBJS@ for replacement functions.
Diffstat (limited to 'util/setenv.c')
-rw-r--r--util/setenv.c51
1 files changed, 51 insertions, 0 deletions
diff --git a/util/setenv.c b/util/setenv.c
new file mode 100644
index 000000000..9175e6f30
--- /dev/null
+++ b/util/setenv.c
@@ -0,0 +1,51 @@
+/* setenv.c - libc replacement function
+ * Copyright (C) 2004 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+#include <config.h>
+#include <string.h>
+#include <errno.h>
+#include <stdlib.h>
+
+/* Implement setenv in terms of putenv. Alas, the nature of setenv is
+ to be leaky... */
+int
+setenv(const char *name, const char *value, int overwrite)
+{
+ char *item=NULL;
+
+ if (name == NULL || *name == '\0' || strchr (name, '=') != NULL)
+ {
+ errno=EINVAL;
+ return -1;
+ }
+
+ item=malloc(strlen(name)+1+strlen(value)+1);
+ if(!item)
+ {
+ errno=ENOMEM;
+ return -1;
+ }
+
+ strcpy(item,name);
+ strcat(item,"=");
+ strcat(item,value);
+
+ return putenv(item);
+}