aboutsummaryrefslogtreecommitdiffstats
path: root/util/secmem.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-12-06 18:24:57 +0000
committerDavid Shaw <[email protected]>2005-12-06 18:24:57 +0000
commita635daa6b6de2bbc40d723337e842ee86e751086 (patch)
tree67ee7ec4613335bdd8e14370e5defc4222e4461c /util/secmem.c
parent* Makefile.am: Some cleanup so we don't build files that are completely (diff)
downloadgnupg-a635daa6b6de2bbc40d723337e842ee86e751086.tar.gz
gnupg-a635daa6b6de2bbc40d723337e842ee86e751086.zip
* mkdtemp.c (mkdtemp): Fix warning.
* secmem.c, assuan-buffer.c, dotlock.c: Fix a few warnings from printf-ing %p where the arg wasn't void *.
Diffstat (limited to 'util/secmem.c')
-rw-r--r--util/secmem.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/util/secmem.c b/util/secmem.c
index a3ab60155..6da58b2e6 100644
--- a/util/secmem.c
+++ b/util/secmem.c
@@ -409,7 +409,7 @@ secmexrealloc( void *p, size_t newsize )
mb = (MEMBLOCK*)((char*)p - ((size_t) &((MEMBLOCK*)0)->u.aligned.c));
size = mb->size;
if (size < sizeof(MEMBLOCK))
- log_bug ("secure memory corrupted at block %p\n", mb);
+ log_bug ("secure memory corrupted at block %p\n", (void *)mb);
size -= ((size_t) &((MEMBLOCK*)0)->u.aligned.c);
if( newsize <= size )