aboutsummaryrefslogtreecommitdiffstats
path: root/util/iobuf.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-12-30 00:50:32 +0000
committerDavid Shaw <[email protected]>2003-12-30 00:50:32 +0000
commit330f042fa4f517079feefcad1f1bc07c6a1dc86e (patch)
tree47adc3c5eff4279e2c0f12e1a514da62ed07926e /util/iobuf.c
parent* misc.c (pull_in_libs): Dead code. Removed. (diff)
downloadgnupg-330f042fa4f517079feefcad1f1bc07c6a1dc86e.tar.gz
gnupg-330f042fa4f517079feefcad1f1bc07c6a1dc86e.zip
* g10u.c: Dead code. Remove.
* Makefile.am: Don't compile g10u.c. * iobuf.c (block_filter): Properly handle a partial body stream that ends with a 5-byte length.
Diffstat (limited to 'util/iobuf.c')
-rw-r--r--util/iobuf.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/util/iobuf.c b/util/iobuf.c
index 5bef61bd0..3d55349b8 100644
--- a/util/iobuf.c
+++ b/util/iobuf.c
@@ -665,6 +665,7 @@ block_filter(void *opaque, int control, IOBUF chain, byte *buf, size_t *ret_len)
break;
}
a->size |= c;
+ a->partial = 2;
}
else { /* next partial body length */
a->size = 1 << (c & 0x1f);