aboutsummaryrefslogtreecommitdiffstats
path: root/util/http.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-02-19 21:03:01 +0000
committerDavid Shaw <[email protected]>2006-02-19 21:03:01 +0000
commitca6c57bc8a746ae579f7c7fd0e385071dfda4e6d (patch)
tree24148c26160062fa84b7a7d3b4df1be81394e063 /util/http.c
parent* configure.ac: Try linking the UINT64_C test program (rather than (diff)
downloadgnupg-ca6c57bc8a746ae579f7c7fd0e385071dfda4e6d.tar.gz
gnupg-ca6c57bc8a746ae579f7c7fd0e385071dfda4e6d.zip
* http.c (send_request): A zero length proxy is the same as no proxy.
Diffstat (limited to '')
-rw-r--r--util/http.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/util/http.c b/util/http.c
index 90a6005eb..b5dc682e4 100644
--- a/util/http.c
+++ b/util/http.c
@@ -518,7 +518,7 @@ send_request( HTTP_HD hd, const char *auth, const char *proxy )
server = *hd->uri->host? hd->uri->host : "localhost";
port = hd->uri->port? hd->uri->port : 80;
- if(proxy)
+ if(proxy && *proxy)
{
PARSED_URI uri;