aboutsummaryrefslogtreecommitdiffstats
path: root/util/fileutil.c
diff options
context:
space:
mode:
authorStefan Bellon <[email protected]>2002-10-28 13:26:44 +0000
committerStefan Bellon <[email protected]>2002-10-28 13:26:44 +0000
commit557f65836d2ad527840db5ecd5550786db55b244 (patch)
tree84b6e6392fb4bf2614614634bc7f2a28fd30e2fb /util/fileutil.c
parent* gnupg.spec.in: Use new path for keyserver helpers, /usr/lib is no longer (diff)
downloadgnupg-557f65836d2ad527840db5ecd5550786db55b244.tar.gz
gnupg-557f65836d2ad527840db5ecd5550786db55b244.zip
filetype support for RISC OS
Diffstat (limited to 'util/fileutil.c')
-rw-r--r--util/fileutil.c6
1 files changed, 4 insertions, 2 deletions
diff --git a/util/fileutil.c b/util/fileutil.c
index c2a2a9df2..0d49ef513 100644
--- a/util/fileutil.c
+++ b/util/fileutil.c
@@ -44,10 +44,12 @@ make_basename(const char *filepath)
char *p;
if ( !(p=strrchr(filepath, DIRSEP_C)) )
- #ifdef HAVE_DRIVE_LETTERS
+#ifdef HAVE_DRIVE_LETTERS
if ( !(p=strrchr(filepath, '\\')) )
if ( !(p=strrchr(filepath, ':')) )
- #endif
+#elif defined(__riscos__)
+ if ( !(p=strrchr(filepath, ':')) )
+#endif
{
return m_strdup(filepath);
}