aboutsummaryrefslogtreecommitdiffstats
path: root/util/fileutil.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-13 09:59:46 +0000
committerWerner Koch <[email protected]>2004-10-13 09:59:46 +0000
commit620ac79ebf8bf6475ed3505b603a4d85a563c314 (patch)
treeaa1a5df7260b166ae3640137188bc153b46a3fe0 /util/fileutil.c
parent* Makefile.am (.S.o): Include MPI_SFLAGS. This is our bug 145. (diff)
downloadgnupg-620ac79ebf8bf6475ed3505b603a4d85a563c314.tar.gz
gnupg-620ac79ebf8bf6475ed3505b603a4d85a563c314.zip
* configure.ac: Actually name the option --disable-finger and not
http. * openfile.c (overwrite_filep, make_outfile_name, open_outfile) (open_sigfile): Use iobuf_is_pipe_filename to check for pipes so that special filesnames are taken into account. This is bug 327. * tdbdump.c (import_ownertrust): Ditto. * sign.c (write_plaintext_packet): Ditto. * progress.c (handle_progress): Ditto. * plaintext.c (handle_plaintext): Ditto. * encode.c (encode_simple, encode_crypt): Ditto. * iobuf.c (iobuf_is_pipe_filename): New. * fileutil.c (is_file_compressed): Use it here.
Diffstat (limited to '')
-rw-r--r--util/fileutil.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/util/fileutil.c b/util/fileutil.c
index c36488640..99aa0776b 100644
--- a/util/fileutil.c
+++ b/util/fileutil.c
@@ -200,7 +200,7 @@ is_file_compressed( const char *s, int *ret_rc )
{ 4, { 0x50, 0x4b, 0x03, 0x04 } }, /* (pk)zip */
};
- if ( !s || (*s == '-' && !s[1]) || !ret_rc )
+ if ( iobuf_is_pipe_filename (s) || !ret_rc )
return 0; /* We can't check stdin or no file was given */
a = iobuf_open( s );