aboutsummaryrefslogtreecommitdiffstats
path: root/tools/symcryptrun.c
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2017-03-07 01:29:37 +0000
committerNIIBE Yutaka <[email protected]>2017-03-07 01:42:28 +0000
commitce37ada87139ef418401f9f35439007a8c04a856 (patch)
tree37892b9994aa10fb2d8a6437f8d6002ed80bbfa2 /tools/symcryptrun.c
parentscd: Close THE_EVENT handle. (diff)
downloadgnupg-ce37ada87139ef418401f9f35439007a8c04a856.tar.gz
gnupg-ce37ada87139ef418401f9f35439007a8c04a856.zip
tools: More portable for openpty use.
* configure.ac (AC_CHECK_HEADERS): Add util.h libutil.h and termios.h. * tools/symcryptrun.c: Include those headers. -- This is for OpenBSD and FreeBSD. Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to '')
-rw-r--r--tools/symcryptrun.c12
1 files changed, 12 insertions, 0 deletions
diff --git a/tools/symcryptrun.c b/tools/symcryptrun.c
index a72b9cf7a..b32d43ac8 100644
--- a/tools/symcryptrun.c
+++ b/tools/symcryptrun.c
@@ -71,9 +71,21 @@
#include <sys/stat.h>
#include <sys/types.h>
#include <sys/wait.h>
+
#ifdef HAVE_PTY_H
#include <pty.h>
+#else
+#ifdef HAVE_TERMIOS_H
+#include <termios.h>
+#endif
+#ifdef HAVE_UTIL_H
+#include <util.h>
+#endif
+#ifdef HAVE_LIBUTIL_H
+#include <libutil.h>
#endif
+#endif
+
#ifdef HAVE_UTMP_H
#include <utmp.h>
#endif