aboutsummaryrefslogtreecommitdiffstats
path: root/tools/gpgconf-comp.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-12-21 19:05:15 +0000
committerWerner Koch <[email protected]>2004-12-21 19:05:15 +0000
commit01f3f2515834876e2131d077e34c3cae4f9a2dc0 (patch)
tree6033e9b66eb3aa8cb46c8fa88cdf80ac29923dba /tools/gpgconf-comp.c
parent* homedir.c: New. Use CSIDL_APPDATA for W32 as the default home (diff)
downloadgnupg-01f3f2515834876e2131d077e34c3cae4f9a2dc0.tar.gz
gnupg-01f3f2515834876e2131d077e34c3cae4f9a2dc0.zip
* preset-passphrase.c (preset_passphrase): Handle --passphrase.
* Makefile.am (gpg_preset_passphrase_LDADD): Reorder libs so that pwquery may use stuff from jnlib. Conditionally add -lwsock2 (gpg_protect_tool_LDADD): Ditto. * preset-passphrase.c (main): Use default_homedir(). (main) [W32]: Initialize sockets. * simple-pwquery.c (agent_open) [W32]: Implement for W32. (readline) [W32]: Use recv instead of read. (writen) [W32]: Use send instead of write. (my_stpcpy): Define a stpcpy replacement so that this file continues to be self-contained. (agent_send_all_options) [W32]: Don't call ttyname. * gnupg-badge-openpgp.eps, gnupg-badge-openpgp.jpg: New * gnupg.texi: Add a logo. * sysnotes.texi: New. * gpgsm.c (main): Use default_homedir(). (main) [W32]: Default to disabled CRL checks. * gpgconf-comp.c (get_config_pathname) [DOSISH]: Detect absolute pathnames with a drive letter.
Diffstat (limited to 'tools/gpgconf-comp.c')
-rw-r--r--tools/gpgconf-comp.c6
1 files changed, 6 insertions, 0 deletions
diff --git a/tools/gpgconf-comp.c b/tools/gpgconf-comp.c
index fe696301c..e4758c1e6 100644
--- a/tools/gpgconf-comp.c
+++ b/tools/gpgconf-comp.c
@@ -1272,7 +1272,13 @@ get_config_pathname (gc_component_t component, gc_backend_t backend)
else
pathname = "";
+#ifdef HAVE_DOSISH_SYSTEM
+ if (!(pathname[0]
+ && pathname[1] == ':'
+ && (pathname[2] == '/' || pathname[2] == '\\')))
+#else
if (pathname[0] != '/')
+#endif
gc_error (1, 0, "Option %s, needed by backend %s, is not absolute",
gc_backend[backend].option_config_filename,
gc_backend[backend].name);