aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorTobias Fella <[email protected]>2023-10-11 10:07:34 +0000
committerTobias Fella <[email protected]>2023-10-24 13:16:58 +0000
commit3e0d1c229b8a15db066fd57cec5bce6dadb1af6b (patch)
treeb4b8a710442aefdfacfb9b95ee4e0a8ed73f2528 /tools/Makefile.am
parenttests:tpm2dtests: Fix tests with SWTPM. (diff)
downloadgnupg-tobias/gpgsum.tar.gz
gnupg-tobias/gpgsum.zip
tools: Add gpgsum tooltobias/gpgsum
* Makefile.am: Add option for building gpgsum * autogen.rc: Add option for building gpgsum * configure.ac: Add option for building gpgsum * tools/Makefile.am: Add sources for gpgsum * tools/gpgsum-w32info.rc: Add new file * tools/gpgsum.c: Add gpsum tool * tools/gpgsum.w32-manifest.in: Add new file
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 769a81a00..c31cba835 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -26,7 +26,8 @@ EXTRA_DIST = \
gpgtar-w32info.rc gpgtar.w32-manifest.in \
gpg-check-pattern-w32info.rc gpg-check-pattern.w32-manifest.in \
gpg-wks-client-w32info.rc gpg-wks-client.w32-manifest.in \
- gpg-card-w32info.rc gpg-card.w32-manifest.in
+ gpg-card-w32info.rc gpg-card.w32-manifest.in \
+ gpgsum-w32info.rc gpgsum.w32-manifest.in
AM_CPPFLAGS =
include $(top_srcdir)/am/cmacros.am
@@ -38,6 +39,7 @@ gpg_card_rc_objs = gpg-card-w32info.o
gpgtar_rc_objs = gpgtar-w32info.o
gpg_check_pattern_rc_objs = gpg-check-pattern-w32info.o
gpg_wks_client_rc_objs = gpg-wks-client-w32info.o
+gpgsum_rc_objs = gpgsum-w32info.o
gpg-connect-agent-w32info.o : gpg-connect-agent.w32-manifest \
../common/w32info-rc.h
@@ -48,6 +50,7 @@ gpg-check-pattern-w32info.o : gpg-check-pattern.w32-manifest \
../common/w32info-rc.h
gpg-wks-client-w32info.o : gpg-wks-client.w32-manifest \
../common/w32info-rc.h
+gpgsum-w32info.o : gpgsum.w32-manifest ../common/w32info-rc.h
endif
@@ -82,6 +85,12 @@ else
noinst_PROGRAMS += gpgtar
endif
+if BUILD_GPGSUM
+ bin_PROGRAMS += gpgsum
+else
+ noinst_PROGRAMS += gpgsum
+endif
+
common_libs = $(libcommon)
commonpth_libs = $(libcommonpth)
@@ -157,6 +166,14 @@ gpgtar_LDADD = $(libcommon) $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
$(LIBINTL) $(NETLIBS) $(LIBICONV) $(W32SOCKLIBS) \
$(gpgtar_rc_objs)
+gpgsum_SOURCES = \
+ gpgsum.c
+
+gpgsum_CFLAGS = $(LIBGCRYPT_CFLAGS) $(GPG_ERROR_CFLAGS)
+gpgsum_LDADD = $(libcommon) $(LIBGCRYPT_LIBS) $(GPG_ERROR_LIBS) \
+ $(LIBINTL) $(NETLIBS) \
+ $(gpgsum_rc_objs)
+
gpg_wks_server_SOURCES = \
gpg-wks-server.c \
gpg-wks.h \