aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2008-10-20 13:53:23 +0000
committerWerner Koch <[email protected]>2008-10-20 13:53:23 +0000
commit0a5f7424660e404e5fd0361b9331d154acf01d6c (patch)
treeb84fb5a994045e12eb326441d8c924094bd915cd /tests
parentFix a bug in estream_snprintf. Found by a failed t-gettime under Windows. (diff)
downloadgnupg-0a5f7424660e404e5fd0361b9331d154acf01d6c.tar.gz
gnupg-0a5f7424660e404e5fd0361b9331d154acf01d6c.zip
Marked all unused args on non-W32 platforms.
Diffstat (limited to '')
-rw-r--r--tests/ChangeLog6
-rw-r--r--tests/asschk.c14
2 files changed, 20 insertions, 0 deletions
diff --git a/tests/ChangeLog b/tests/ChangeLog
index 305303776..973235f32 100644
--- a/tests/ChangeLog
+++ b/tests/ChangeLog
@@ -1,3 +1,9 @@
+2008-10-20 Werner Koch <[email protected]>
+
+ * asschk.c (cmd_echo): Mark unused arg.
+ (cmd_send, cmd_expect_ok, cmd_expect_err, cmd_pipeserver)
+ (cmd_quit_if, cmd_fail_if): Ditto.
+
2008-09-29 Werner Koch <[email protected]>
* Makefile.am (TESTS): Remove tests.
diff --git a/tests/asschk.c b/tests/asschk.c
index 176fcac6f..c4a50acb3 100644
--- a/tests/asschk.c
+++ b/tests/asschk.c
@@ -673,6 +673,7 @@ cmd_let (const char *assign_to, char *arg)
static void
cmd_echo (const char *assign_to, char *arg)
{
+ (void)assign_to;
if (!opt_no_echo)
printf ("%s\n", arg);
}
@@ -680,6 +681,7 @@ cmd_echo (const char *assign_to, char *arg)
static void
cmd_send (const char *assign_to, char *arg)
{
+ (void)assign_to;
if (opt_verbose)
fprintf (stderr, "sending `%s'\n", arg);
write_assuan (server_send_fd, arg);
@@ -706,6 +708,9 @@ handle_status_line (char *arg)
static void
cmd_expect_ok (const char *assign_to, char *arg)
{
+ (void)assign_to;
+ (void)arg;
+
if (opt_verbose)
fprintf (stderr, "expecting OK\n");
do
@@ -724,6 +729,9 @@ cmd_expect_ok (const char *assign_to, char *arg)
static void
cmd_expect_err (const char *assign_to, char *arg)
{
+ (void)assign_to;
+ (void)arg;
+
if (opt_verbose)
fprintf (stderr, "expecting ERR\n");
do
@@ -795,6 +803,8 @@ cmd_createfile (const char *assign_to, char *arg)
static void
cmd_pipeserver (const char *assign_to, char *arg)
{
+ (void)assign_to;
+
if (!*arg)
die ("syntax error: servername missing");
@@ -805,6 +815,8 @@ cmd_pipeserver (const char *assign_to, char *arg)
static void
cmd_quit_if(const char *assign_to, char *arg)
{
+ (void)assign_to;
+
if (eval_boolean (arg))
exit (0);
}
@@ -812,6 +824,8 @@ cmd_quit_if(const char *assign_to, char *arg)
static void
cmd_fail_if(const char *assign_to, char *arg)
{
+ (void)assign_to;
+
if (eval_boolean (arg))
exit (1);
}