aboutsummaryrefslogtreecommitdiffstats
path: root/tests/openpgp/gpgtar.scm
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-01-07 16:01:45 +0000
committerJustus Winter <[email protected]>2016-06-17 09:57:12 +0000
commit9609cb20e4caee739b9fc4fd36797029d2970041 (patch)
tree052eaa0ad4afda93f4bd7eec4c90886cf72f778e /tests/openpgp/gpgtar.scm
parenttests/gpgscm: Add a TinySCHEME-based test driver. (diff)
downloadgnupg-9609cb20e4caee739b9fc4fd36797029d2970041.tar.gz
gnupg-9609cb20e4caee739b9fc4fd36797029d2970041.zip
tests/openpgp: Reimplement tests in Scheme.
* Makefile.am: Build the test infrastructure on Windows. * tests/openpgp/Makefile.am (required_pgms): Add gpgscm. (TESTS_ENVIRONMENT): Make sure gpgscm and the libraries are found. (TESTS): Replace tests with the new Scheme implementations. * tests/openpgp/4gb-packet.scm: New file. * tests/openpgp/README: Likewise. * tests/openpgp/armdetach.scm: Likewise. * tests/openpgp/armdetachm.scm: Likewise. * tests/openpgp/armencrypt.scm: Likewise. * tests/openpgp/armencryptp.scm: Likewise. * tests/openpgp/armor.scm: Likewise. * tests/openpgp/armsignencrypt.scm: Likewise. * tests/openpgp/armsigs.scm: Likewise. * tests/openpgp/clearsig.scm: Likewise. * tests/openpgp/conventional-mdc.scm: Likewise. * tests/openpgp/conventional.scm: Likewise. * tests/openpgp/decrypt-dsa.scm: Likewise. * tests/openpgp/decrypt.scm: Likewise. * tests/openpgp/default-key.scm: Likewise. * tests/openpgp/defs.scm: Likewise. * tests/openpgp/detach.scm: Likewise. * tests/openpgp/detachm.scm: Likewise. * tests/openpgp/ecc.scm: Likewise. * tests/openpgp/encrypt-dsa.scm: Likewise. * tests/openpgp/encrypt.scm: Likewise. * tests/openpgp/encryptp.scm: Likewise. * tests/openpgp/finish.scm: Likewise. * tests/openpgp/genkey1024.scm: Likewise. * tests/openpgp/gpgtar.scm: Likewise. * tests/openpgp/import.scm: Likewise. * tests/openpgp/mds.scm: Likewise. * tests/openpgp/multisig.scm: Likewise. * tests/openpgp/run-tests.scm: Likewise. * tests/openpgp/seat.scm: Likewise. * tests/openpgp/setup.scm: Likewise. * tests/openpgp/signencrypt-dsa.scm: Likewise. * tests/openpgp/signencrypt.scm: Likewise. * tests/openpgp/sigs-dsa.scm: Likewise. * tests/openpgp/sigs.scm: Likewise. * tests/openpgp/use-exact-key.scm: Likewise. * tests/openpgp/verify.scm: Likewise. * tests/openpgp/version.scm: Likewise. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'tests/openpgp/gpgtar.scm')
-rwxr-xr-xtests/openpgp/gpgtar.scm88
1 files changed, 88 insertions, 0 deletions
diff --git a/tests/openpgp/gpgtar.scm b/tests/openpgp/gpgtar.scm
new file mode 100755
index 000000000..d406079f5
--- /dev/null
+++ b/tests/openpgp/gpgtar.scm
@@ -0,0 +1,88 @@
+#!/usr/bin/env gpgscm
+
+;; Copyright (C) 2016 g10 Code GmbH
+;;
+;; This file is part of GnuPG.
+;;
+;; GnuPG is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3 of the License, or
+;; (at your option) any later version.
+;;
+;; GnuPG is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+;;
+;; You should have received a copy of the GNU General Public License
+;; along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+(load (with-path "defs.scm"))
+
+(unless (= 0 (call `(,(tool 'gpgtar) --help)))
+ (skip "gpgtar not installed"))
+
+(define testfiles (append plain-files data-files))
+(define gpgargs
+ (if have-opt-always-trust
+ "--no-permission-warning --always-trust"
+ "--no-permission-warning"))
+
+(define (do-test create-flags inspect-flags extract-flags)
+ (lettmp (archive)
+ (call-check `(,(tool 'gpgtar) --gpg ,(tool 'gpg) --gpg-args ,gpgargs
+ ,@create-flags
+ --output ,archive
+ ,@testfiles))
+ (tr:do
+ (tr:pipe-do
+ (pipe:spawn `(,(tool 'gpgtar) --gpg ,(tool 'gpg) --gpg-args ,gpgargs
+ --list-archive ,@inspect-flags
+ ,archive)))
+ (tr:call-with-content
+ (lambda (c)
+ (unless (all (lambda (f) (string-contains? c f)) testfiles)
+ (error "some file(s) are missing from archive")))))
+
+ (with-temporary-working-directory
+ (call-check `(,(tool 'gpgtar) --gpg ,(tool 'gpg) --gpg-args ,gpgargs
+ --tar-args --directory=.
+ --decrypt
+ ,@extract-flags
+ ,archive))
+
+ (for-each
+ (lambda (f) (unless (call-with-input-file f (lambda (x) #t))
+ (error (string-append "missing file: " f))))
+ testfiles))))
+
+(info "Checking gpgtar without encryption")
+(do-test `(--skip-crypto --encrypt) '(--skip-crypto) '(--skip-crypto))
+
+(info "Checking gpgtar with asymmetric encryption")
+(do-test `(--encrypt --recipient ,usrname2) '() '())
+
+(info "Checking gpgtar with asymmetric encryption and signature")
+(do-test `(--encrypt --recipient ,usrname2 --sign --local-user ,usrname3)
+ '() '())
+
+(info "Checking gpgtar with signature")
+(do-test `(--sign --local-user ,usrname3) '() '())
+
+(lettmp (passphrasefile)
+ (letfd ((fd (open passphrasefile (logior O_WRONLY O_CREAT O_BINARY) #o600)))
+ (display "streng geheimes hupsipupsi" (fdopen fd "wb")))
+
+ (let ((ppflags `(--gpg-args ,(string-append "--passphrase-file="
+ passphrasefile))))
+ (info "Checking gpgtar with symmetric encryption")
+ (do-test `(,@ppflags --symmetric) ppflags ppflags)
+
+ (info "Checking gpgtar with symmetric encryption and chosen cipher")
+ (do-test `(,@ppflags --symmetric --gpg-args
+ ,(string-append "--cipher=" (car all-cipher-algos)))
+ ppflags ppflags)
+
+ (info "Checking gpgtar with both symmetric and asymmetric encryption")
+ (do-test `(,@ppflags --symmetric --encrypt --recipient ,usrname2
+ --sign --local-user ,usrname3) ppflags ppflags)))