aboutsummaryrefslogtreecommitdiffstats
path: root/tests/openpgp/defs.scm
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2016-08-08 04:24:02 +0000
committerNIIBE Yutaka <[email protected]>2016-08-08 04:24:02 +0000
commit7dcad0d3503ac0d75e09efb16246dd78518986fc (patch)
tree5edcc2fb544251c3eb4585eb3f9587ccf35f9304 /tests/openpgp/defs.scm
parentagent: Fix long standing regression tracking the connection count. (diff)
downloadgnupg-7dcad0d3503ac0d75e09efb16246dd78518986fc.tar.gz
gnupg-7dcad0d3503ac0d75e09efb16246dd78518986fc.zip
tests: Add openpgp/gpgv-forged-keyring.scm.
* tests/openpgp/gpgv-forged-keyring.scm: New. * tests/openpgp/forged-keyring.gpg: New. * tests/openpgp/Makefile.am (TESTS): Add gpgv-forged-keyring.scm. * tests/openpgp/defs.scm (tools): Add GPGV. (GPGV): New. -- Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to '')
-rw-r--r--tests/openpgp/defs.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/openpgp/defs.scm b/tests/openpgp/defs.scm
index 2cbad46c5..4a968da93 100644
--- a/tests/openpgp/defs.scm
+++ b/tests/openpgp/defs.scm
@@ -53,6 +53,7 @@
(define tools
'((gpg "GPG" "g10/gpg")
+ (gpgv "GPGV" "g10/gpgv")
(gpg-agent "GPG_AGENT" "agent/gpg-agent")
(gpg-connect-agent "GPG_CONNECT_AGENT" "tools/gpg-connect-agent")
(gpgconf "GPGCONF" "tools/gpgconf")
@@ -78,6 +79,7 @@
(define GPG `(,(tool 'gpg) --no-permission-warning
,@(if have-opt-always-trust '(--always-trust) '())))
+(define GPGV `(,(tool 'gpgv)))
(define PINENTRY (tool 'pinentry))
(define (tr:gpg input args)