aboutsummaryrefslogtreecommitdiffstats
path: root/tests/migrations/setup.scm
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-12-19 16:28:43 +0000
committerJustus Winter <[email protected]>2016-12-19 16:47:10 +0000
commit65a0d6a24e6299682793f213a9d2bae17c5b12d9 (patch)
treecfc4528afa70d8886bf4696dba5e0a5f2bc172eb /tests/migrations/setup.scm
parenttests: Use sequential test runner if only one test is given. (diff)
downloadgnupg-65a0d6a24e6299682793f213a9d2bae17c5b12d9.tar.gz
gnupg-65a0d6a24e6299682793f213a9d2bae17c5b12d9.zip
tests: Use the common test framework for the migration tests.
* tests/migrations/Makefile.am (reqired_pgms): Add 'gpgscm'. (TESTS_ENVIRONMENT): Populate. (TESTS): Rename to 'XTESTS'. (xcheck): New target. (EXTRA_DIST): Add new files. (CLEANFILES): Remove log files. * tests/migrations/common.scm: Honor 'verbose', fix paths. * tests/migrations/run-tests.scm: New file. * tests/migrations/setup.scm: Likewise. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rw-r--r--tests/migrations/setup.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/migrations/setup.scm b/tests/migrations/setup.scm
new file mode 100644
index 000000000..76a584061
--- /dev/null
+++ b/tests/migrations/setup.scm
@@ -0,0 +1,20 @@
+#!/usr/bin/env gpgscm
+
+;; Copyright (C) 2016 g10 Code GmbH
+;;
+;; This file is part of GnuPG.
+;;
+;; GnuPG is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3 of the License, or
+;; (at your option) any later version.
+;;
+;; GnuPG is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+;;
+;; You should have received a copy of the GNU General Public License
+;; along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+;; Nothing to do for now.