aboutsummaryrefslogtreecommitdiffstats
path: root/tests/migrations/from-classic.test
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-06-21 16:10:18 +0000
committerJustus Winter <[email protected]>2016-06-21 16:15:30 +0000
commitf548383d9af912bf93217068cc8aa99a9a6eda93 (patch)
tree61786a73598fb2ad30eba9bd9e98d7be4543e117 /tests/migrations/from-classic.test
parentgpgscm: Add more file handling functions. (diff)
downloadgnupg-f548383d9af912bf93217068cc8aa99a9a6eda93.tar.gz
gnupg-f548383d9af912bf93217068cc8aa99a9a6eda93.zip
tests/migrations: Convert to Scheme and re-enable.
* configure.ac: Re-enable. * tests/Makefile.am: Likewise. * tests/migrations/Makefile.am (TESTS): Use Scheme tests. * tests/migrations/common.scm: New file. * tests/migrations/extended-private-key-format.scm: Likewise. * tests/migrations/from-classic.scm: Likewise. * tests/migrations/extended-private-key-format.test: Drop file. * tests/migrations/from-classic.test: Drop file. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rwxr-xr-xtests/migrations/from-classic.test77
1 files changed, 0 insertions, 77 deletions
diff --git a/tests/migrations/from-classic.test b/tests/migrations/from-classic.test
deleted file mode 100755
index 9b81d452b..000000000
--- a/tests/migrations/from-classic.test
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/sh
-# Copyright 2016 g10 Code GmbH
-#
-# This file is free software; as a special exception the author gives
-# unlimited permission to copy and/or distribute it, with or without
-# modifications, as long as this notice is preserved. This file is
-# distributed in the hope that it will be useful, but WITHOUT ANY
-# WARRANTY, to the extent permitted by law; without even the implied
-# warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-
-if [ -z "$srcdir" ]; then
- echo "not called from make" >&2
- exit 1
-fi
-
-unset GNUPGHOME
-set -e
-
-# (We may not use a relative name for gpg-agent.)
-GPG_AGENT="$(cd ../../agent && /bin/pwd)/gpg-agent"
-GPG="../../g10/gpg --no-permission-warning --no-greeting --no-secmem-warning
---batch --agent-program=${GPG_AGENT}|--debug-quick-random"
-
-TEST="from-classic"
-
-setup_home()
-{
- XGNUPGHOME="`mktemp -d`"
- rm -rf -- scratch
- mkdir -p "$XGNUPGHOME"
- for F in $srcdir/$TEST.gpghome/*.asc; do
- $GPG --dearmor <"$F" >"$XGNUPGHOME/`basename $F .asc`"
- done
- chmod go-rwx $XGNUPGHOME/*
- export GNUPGHOME="$XGNUPGHOME"
-}
-
-cleanup_home()
-{
- rm -rf -- "$XGNUPGHOME"
-}
-
-trigger_migration()
-{
- $GPG --list-secret-keys >/dev/null 2>&1
-}
-
-assert_migrated()
-{
- test -f $GNUPGHOME/.gpg-v21-migrated
-
- for KEY in D74C5F22 C40FDECF ECABF51D; do
- $GPG --list-secret-keys $KEY >/dev/null
- done
-}
-
-setup_home
-trigger_migration
-assert_migrated
-cleanup_home
-
-# Test with an existing private-keys-v1.d.
-setup_home
-mkdir "$GNUPGHOME/private-keys-v1.d"
-trigger_migration
-assert_migrated
-cleanup_home
-
-# Test with an existing private-keys-v1.d with weird permissions.
-setup_home
-mkdir "$GNUPGHOME/private-keys-v1.d"
-chmod 0 "$GNUPGHOME/private-keys-v1.d"
-trigger_migration
-assert_migrated
-cleanup_home
-
-# XXX Check a case where the migration fails.