aboutsummaryrefslogtreecommitdiffstats
path: root/tests/migrations/from-classic.scm
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-06-21 16:10:18 +0000
committerJustus Winter <[email protected]>2016-06-21 16:15:30 +0000
commitf548383d9af912bf93217068cc8aa99a9a6eda93 (patch)
tree61786a73598fb2ad30eba9bd9e98d7be4543e117 /tests/migrations/from-classic.scm
parentgpgscm: Add more file handling functions. (diff)
downloadgnupg-f548383d9af912bf93217068cc8aa99a9a6eda93.tar.gz
gnupg-f548383d9af912bf93217068cc8aa99a9a6eda93.zip
tests/migrations: Convert to Scheme and re-enable.
* configure.ac: Re-enable. * tests/Makefile.am: Likewise. * tests/migrations/Makefile.am (TESTS): Use Scheme tests. * tests/migrations/common.scm: New file. * tests/migrations/extended-private-key-format.scm: Likewise. * tests/migrations/from-classic.scm: Likewise. * tests/migrations/extended-private-key-format.test: Drop file. * tests/migrations/from-classic.test: Drop file. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rwxr-xr-xtests/migrations/from-classic.scm65
1 files changed, 65 insertions, 0 deletions
diff --git a/tests/migrations/from-classic.scm b/tests/migrations/from-classic.scm
new file mode 100755
index 000000000..6b98eeb7f
--- /dev/null
+++ b/tests/migrations/from-classic.scm
@@ -0,0 +1,65 @@
+#!/usr/bin/env gpgscm
+
+;; Copyright (C) 2016 g10 Code GmbH
+;;
+;; This file is part of GnuPG.
+;;
+;; GnuPG is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3 of the License, or
+;; (at your option) any later version.
+;;
+;; GnuPG is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+;;
+;; You should have received a copy of the GNU General Public License
+;; along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+(load (with-path "common.scm"))
+
+(define src-gpghome (in-srcdir "from-classic.gpghome"))
+
+(define (setup)
+ (for-each-p'
+ "Preparing home directory"
+ (lambda (f) (dearmor f (basename-suffix f ".asc")))
+ (lambda (f) (basename-suffix f ".asc"))
+ (glob (string-append src-gpghome "/*.asc")))
+ (setenv "GNUPGHOME" (getcwd) #t))
+
+(define (trigger-migration)
+ (call-check `(,@GPG --list-secret-keys)))
+
+(define (assert-migrated)
+ (unless (file-exists? ".gpg-v21-migrated")
+ (error "Not migrated"))
+
+ (for-each
+ (lambda (keyid)
+ (catch (error "Key not found:" keyid)
+ (call-check `(,@GPG --list-secret-keys ,keyid))))
+ '("D74C5F22" "C40FDECF" "ECABF51D")))
+
+(info "Testing a clean migration ...")
+(with-temporary-working-directory
+ (setup)
+ (trigger-migration)
+ (assert-migrated))
+
+(info "Testing a migration with existing private-keys-v1.d ...")
+(with-temporary-working-directory
+ (setup)
+ (mkdir "private-keys-v1.d" "-rwx")
+ (trigger-migration)
+ (assert-migrated))
+
+(info "Testing a migration with existing but weird private-keys-v1.d ...")
+(with-temporary-working-directory
+ (setup)
+ (mkdir "private-keys-v1.d" "")
+ (trigger-migration)
+ (assert-migrated))
+
+;; XXX Check a case where the migration fails.