aboutsummaryrefslogtreecommitdiffstats
path: root/tests/migrations/common.scm
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-12-19 16:28:43 +0000
committerJustus Winter <[email protected]>2016-12-19 16:47:10 +0000
commit65a0d6a24e6299682793f213a9d2bae17c5b12d9 (patch)
treecfc4528afa70d8886bf4696dba5e0a5f2bc172eb /tests/migrations/common.scm
parenttests: Use sequential test runner if only one test is given. (diff)
downloadgnupg-65a0d6a24e6299682793f213a9d2bae17c5b12d9.tar.gz
gnupg-65a0d6a24e6299682793f213a9d2bae17c5b12d9.zip
tests: Use the common test framework for the migration tests.
* tests/migrations/Makefile.am (reqired_pgms): Add 'gpgscm'. (TESTS_ENVIRONMENT): Populate. (TESTS): Rename to 'XTESTS'. (xcheck): New target. (EXTRA_DIST): Add new files. (CLEANFILES): Remove log files. * tests/migrations/common.scm: Honor 'verbose', fix paths. * tests/migrations/run-tests.scm: New file. * tests/migrations/setup.scm: Likewise. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'tests/migrations/common.scm')
-rw-r--r--tests/migrations/common.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/tests/migrations/common.scm b/tests/migrations/common.scm
index 944d4f662..30ac62ba1 100644
--- a/tests/migrations/common.scm
+++ b/tests/migrations/common.scm
@@ -18,14 +18,16 @@
(if (string=? "" (getenv "srcdir"))
(error "not called from make"))
-(setenv "GNUPGHOME" "" #t)
+(let ((verbose (string->number (getenv "verbose"))))
+ (if (number? verbose)
+ (*set-verbose!* verbose)))
(define (qualify executable)
(string-append executable (getenv "EXEEXT")))
;; We may not use a relative name for gpg-agent.
-(define GPG-AGENT (qualify (string-append (getcwd) "/../../agent/gpg-agent")))
-(define GPG `(,(qualify (string-append (getcwd) "/../../g10/gpg"))
+(define GPG-AGENT (path-join (getenv "objdir") "agent" (qualify "gpg-agent")))
+(define GPG `(,(path-join (getenv "objdir") "g10" (qualify "gpg"))
--no-permission-warning --no-greeting
--no-secmem-warning --batch
,(string-append "--agent-program=" GPG-AGENT
@@ -33,7 +35,7 @@
(define GPG-no-batch
(filter (lambda (arg) (not (equal? arg '--batch))) GPG))
-(define GPGTAR (qualify (string-append (getcwd) "/../../tools/gpgtar")))
+(define GPGTAR (path-join (getenv "objdir") "tools" (qualify "gpgtar")))
(define (untar-armored source-name)
(pipe:do