aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gpgscm/repl.scm
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-01-06 10:55:25 +0000
committerJustus Winter <[email protected]>2016-06-17 09:57:12 +0000
commitd2ce3f9eee34e380536049c0c9d26ed66273f094 (patch)
tree15fc9c7e1a715b4364d44508bacedeba03b3fe63 /tests/gpgscm/repl.scm
parenttests/gpgscm: Foreign objects support for TinySCHEME. (diff)
downloadgnupg-d2ce3f9eee34e380536049c0c9d26ed66273f094.tar.gz
gnupg-d2ce3f9eee34e380536049c0c9d26ed66273f094.zip
tests/gpgscm: Add a TinySCHEME-based test driver.
* configure.ac: Add new component. * tests/Makefile.am: Likewise. * tests/gpgscm/Makefile.am: New file. * tests/gpgscm/ffi-private.h: Likewise. * tests/gpgscm/ffi.c: Likewise. * tests/gpgscm/ffi.h: Likewise. * tests/gpgscm/ffi.scm: Likewise. * tests/gpgscm/lib.scm: Likewise. * tests/gpgscm/main.c: Likewise. * tests/gpgscm/private.h: Likewise. * tests/gpgscm/repl.scm: Likewise. * tests/gpgscm/scheme-config.h: Likewise. * tests/gpgscm/t-child.c: Likewise. * tests/gpgscm/t-child.scm: Likewise. * tests/gpgscm/tests.scm: Likewise. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to 'tests/gpgscm/repl.scm')
-rw-r--r--tests/gpgscm/repl.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/tests/gpgscm/repl.scm b/tests/gpgscm/repl.scm
new file mode 100644
index 000000000..896554faf
--- /dev/null
+++ b/tests/gpgscm/repl.scm
@@ -0,0 +1,50 @@
+;; A read-evaluate-print-loop for gpgscm.
+;;
+;; Copyright (C) 2016 g10 Code GmbH
+;;
+;; This file is part of GnuPG.
+;;
+;; GnuPG is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3 of the License, or
+;; (at your option) any later version.
+;;
+;; GnuPG is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+;;
+;; You should have received a copy of the GNU General Public License
+;; along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+;; Interactive repl using 'prompt' function. P must be a function
+;; that given the current entered prefix returns the prompt to
+;; display.
+(define (repl p)
+ (let ((repl-environment (make-environment)))
+ (call/cc
+ (lambda (exit)
+ (let loop ((prefix ""))
+ (let ((line (prompt (p prefix))))
+ (if (and (not (eof-object? line)) (= 0 (string-length line)))
+ (exit (loop prefix)))
+ (if (not (eof-object? line))
+ (let* ((next (string-append prefix line))
+ (c (catch (begin (echo "Parse error:" *error*)
+ (loop prefix))
+ (read (open-input-string next)))))
+ (if (not (eof-object? c))
+ (begin
+ (catch (echo "Error:" *error*)
+ (echo " ===>" (eval c repl-environment)))
+ (exit (loop ""))))
+ (exit (loop next))))))))))
+
+(define (prompt-append-prefix prompt prefix)
+ (string-append prompt (if (> (string-length prefix) 0)
+ (string-append prefix "...")
+ "> ")))
+
+;; Default repl run by main.c.
+(define (interactive-repl)
+ (repl (lambda (p) (prompt-append-prefix "gpgscm " p))))