aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gpgscm/ffi.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2017-08-08 15:28:25 +0000
committerWerner Koch <[email protected]>2017-08-08 15:49:53 +0000
commitfb21aa8b50367e2afa13bad73fc21d6f01a97e18 (patch)
treea448e1a6ef0523166568858669e0e6bb866670a6 /tests/gpgscm/ffi.c
parentgpgscm: Make the test summary stand out (diff)
downloadgnupg-fb21aa8b50367e2afa13bad73fc21d6f01a97e18.tar.gz
gnupg-fb21aa8b50367e2afa13bad73fc21d6f01a97e18.zip
build: New configure option --enable-all-tests.
* configure.ac: New option --enable-all-tests. * tests/gpgscm/ffi.c (ffi_init): New gloabl var *run-all-tests*. * tests/openpgp/all-tests.scm (all-tests): Use that var instead of *maintainer-mode*. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Add --enable-all-tests. -- It is better to have a separate option to run all tests than to put this on top of --enable-maintainer-mode. This way we can also make sure to run all tests during "make distcheck". Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--tests/gpgscm/ffi.c8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/gpgscm/ffi.c b/tests/gpgscm/ffi.c
index 4c2148a26..dde5b5282 100644
--- a/tests/gpgscm/ffi.c
+++ b/tests/gpgscm/ffi.c
@@ -1450,6 +1450,14 @@ ffi_init (scheme *sc, const char *argv0, const char *scriptname,
#endif
);
+ ffi_define (sc, "*run-all-tests*",
+#if RUN_ALL_TESTS
+ sc->T
+#else
+ sc->F
+#endif
+ );
+
ffi_define (sc, "*stdin*",
sc->vptr->mk_port_from_file (sc, stdin, port_input));