aboutsummaryrefslogtreecommitdiffstats
path: root/sm/sign.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-05-14 16:51:00 +0000
committerWerner Koch <[email protected]>2002-05-14 16:51:00 +0000
commitc7ceb874c28c0cae77870629f492d61340384944 (patch)
treec01b633e889a6a2b3e32d56bf4a5ccb492602863 /sm/sign.c
parent* errors.h: Added STARUS_EXPSIG and STATUS_EXPKEYSIG. (diff)
downloadgnupg-c7ceb874c28c0cae77870629f492d61340384944.tar.gz
gnupg-c7ceb874c28c0cae77870629f492d61340384944.zip
sm/
* gpgsm.c: New option --faked-system-time * sign.c (gpgsm_sign): And use it here. * certpath.c (gpgsm_validate_path): Ditto. common/ * gettime.c: New. agent/ * cache.c (housekeeping, agent_put_cache): Use our time() wrapper. / * doc/: New * configure.ac, Makefile.am: Added doc/
Diffstat (limited to '')
-rw-r--r--sm/sign.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/sm/sign.c b/sm/sign.c
index 2781baa84..46fa170ba 100644
--- a/sm/sign.c
+++ b/sm/sign.c
@@ -393,7 +393,7 @@ gpgsm_sign (CTRL ctrl, int data_fd, int detached, FILE *out_fp)
}
}
- signed_at = time (NULL);
+ signed_at = gnupg_get_time ();
err = ksba_cms_set_signing_time (cms, signer, signed_at);
if (err)
{