aboutsummaryrefslogtreecommitdiffstats
path: root/sm/misc.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-06-01 15:46:01 +0000
committerWerner Koch <[email protected]>2005-06-01 15:46:01 +0000
commitcad9562436e61cdaf1a2f03ba96bcc82077205e6 (patch)
tree6db1dde6998d0ad1ae13a4581f66cace736a2399 /sm/misc.c
parent* agent.h (out_of_core): s/__inline__/inine. Noted by Ray Link. (diff)
downloadgnupg-cad9562436e61cdaf1a2f03ba96bcc82077205e6.tar.gz
gnupg-cad9562436e61cdaf1a2f03ba96bcc82077205e6.zip
* configure.ac (gl_INIT): Add gnulib stuff.
(fseeko, ftello, ttyname, isascii): Replaced the AC_REPLACE_FUNCS by a simple check. (putc_unlocked): Removed check. Not used. (strsep, mkdtemp, asprintf): Replaced checks by gnulib checks. (xsize): Added will probably come handy soon. (CFLAGS): Use -Wformat-security instead of -Wformat-nonliteral. Add --Wno-format-y2k. * gl/, gl/m4/: New. * gpg-agent.c: Include setenv.h. * Makefile.am (AM_CPPFLAGS): Added. * util.h: Add some includes for gnulib. (ttyname, isascii): Define them inline. * fseeko.c, ftello.c: Removed. * strsep.c, mkdtemp.c: Removed. * ttyname.c, isascii.c: Removed. * mkdtemp.c: Removed. * exec.c: Include mkdtemp.h * keybox-file.c (ftello) [!HAVE_FSEEKO]: New replacement function. Copied from ../common/ftello.c. * keybox-update.c (fseeko) [!HAVE_FSEEKO]: New replacement function. Copied from ../common/iobuf.c. * scdaemon.c: Include mkdtemp.h. * misc.c: Include setenv.h. * symcryptrun.c: Include mkdtemp.h.
Diffstat (limited to '')
-rw-r--r--sm/misc.c1
1 files changed, 1 insertions, 0 deletions
diff --git a/sm/misc.c b/sm/misc.c
index 36c4dda70..cd072ce6b 100644
--- a/sm/misc.c
+++ b/sm/misc.c
@@ -31,6 +31,7 @@
#include "gpgsm.h"
#include "i18n.h"
+#include "setenv.h"
/* Setup the environment so that the pinentry is able to get all
required information. This is used prior to an exec of the