aboutsummaryrefslogtreecommitdiffstats
path: root/sm/gpgsm.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-08-06 16:14:10 +0000
committerWerner Koch <[email protected]>2004-08-06 16:14:10 +0000
commitf96ad015d8ac7611213ff84227f97c7c6eb25fe7 (patch)
treeaa3915b02549ee4b29f4048b702f95cf152c1b44 /sm/gpgsm.c
parent* configure.ac: Changed tests for libusb to also suuport the (diff)
downloadgnupg-f96ad015d8ac7611213ff84227f97c7c6eb25fe7.tar.gz
gnupg-f96ad015d8ac7611213ff84227f97c7c6eb25fe7.zip
* gpgsm.c: New option --with-ephemeral-keys.
* keylist.c (list_internal_keys): Set it here. (list_cert_raw): And indicate those keys. Changed all our callers to pass the new arg HD through.
Diffstat (limited to '')
-rw-r--r--sm/gpgsm.c3
1 files changed, 3 insertions, 0 deletions
diff --git a/sm/gpgsm.c b/sm/gpgsm.c
index bf053b7a5..5fb80a0de 100644
--- a/sm/gpgsm.c
+++ b/sm/gpgsm.c
@@ -170,6 +170,7 @@ enum cmd_and_opt_values {
oWithColons,
oWithKeyData,
oWithValidation,
+ oWithEphemeralKeys,
oSkipVerify,
oCompressKeys,
oCompressSigs,
@@ -404,6 +405,7 @@ static ARGPARSE_OPTS opts[] = {
{ oWithKeyData,"with-key-data", 0, "@"},
{ oWithValidation, "with-validation", 0, "@"},
{ oWithMD5Fingerprint, "with-md5-fingerprint", 0, "@"},
+ { oWithEphemeralKeys, "with-ephemeral-keys", 0, "@"},
{ aListKeys, "list-key", 0, "@" }, /* alias */
{ aListSigs, "list-sig", 0, "@" }, /* alias */
{ aListSigs, "check-sig",0, "@" }, /* alias */
@@ -1078,6 +1080,7 @@ main ( int argc, char **argv)
case oWithKeyData: opt.with_key_data=1; /* fall thru */
case oWithColons: ctrl.with_colons = 1; break;
case oWithValidation: ctrl.with_validation=1; break;
+ case oWithEphemeralKeys: opt.with_ephemeral_keys=1; break;
case oSkipVerify: opt.skip_verify=1; break;