aboutsummaryrefslogtreecommitdiffstats
path: root/sm/gpgsm.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-06-12 09:54:57 +0000
committerWerner Koch <[email protected]>2002-06-12 09:54:57 +0000
commit0dec11fbe7ae416d1573b3feccf9953ae939de68 (patch)
treee50e7d6082329bb53bbfea7431e581ca5dce9741 /sm/gpgsm.c
parent* gpgsm.c (main): New command --list-sigs (diff)
downloadgnupg-0dec11fbe7ae416d1573b3feccf9953ae939de68.tar.gz
gnupg-0dec11fbe7ae416d1573b3feccf9953ae939de68.zip
* sign.c (hash_and_copy_data): New.
(gpgsm_sign): Implemented normal (non-detached) signatures. * gpgsm.c (main): Ditto. * certpath.c (gpgsm_validate_path): Special error handling for no policy match. * configure.ac (NEED_LIBKSBA_VERSION): We need 0.4.3 now.
Diffstat (limited to '')
-rw-r--r--sm/gpgsm.c11
1 files changed, 6 insertions, 5 deletions
diff --git a/sm/gpgsm.c b/sm/gpgsm.c
index 3aeddd845..f01ffc709 100644
--- a/sm/gpgsm.c
+++ b/sm/gpgsm.c
@@ -1080,13 +1080,14 @@ main ( int argc, char **argv)
break;
case aSign: /* sign the given file */
- /* FIXME: we can only do detached sigs for now and we don't
- handle --output yet. We should also allow to concatenate
- multiple files for signing because that is what gpg does.*/
+ /* FIXME: W we don't handle --output yet. We should also allow
+ to concatenate multiple files for signing because that is
+ what gpg does.*/
if (!argc)
- gpgsm_sign (&ctrl, 0, 1, stdout); /* create from stdin */
+ gpgsm_sign (&ctrl, 0, detached_sig, stdout); /* create from stdin */
else if (argc == 1)
- gpgsm_sign (&ctrl, open_read (*argv), 1, stdout); /* from file */
+ gpgsm_sign (&ctrl, open_read (*argv),
+ detached_sig, stdout); /* from file */
else
wrong_args (_("--sign [datafile]"));
break;