aboutsummaryrefslogtreecommitdiffstats
path: root/sm/gpgsm.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-12-06 18:28:56 +0000
committerWerner Koch <[email protected]>2004-12-06 18:28:56 +0000
commit0a058ac53c45f65a075aa87d3fd687a685c6a775 (patch)
tree498a6a7aaeb3e9361dafc0ba43fad60c8e9f6bf2 /sm/gpgsm.c
parent* configure.ac (have_w32_system): New. Disable Pth checks for W32. (diff)
downloadgnupg-0a058ac53c45f65a075aa87d3fd687a685c6a775.tar.gz
gnupg-0a058ac53c45f65a075aa87d3fd687a685c6a775.zip
* exechelp.h, exechelp.c: New. Based on code from ../sm/import.c.
* gpgsm.c (run_protect_tool) [_WIN32]: Disabled. * import.c (popen_protect_tool): Simplified by making use of gnupg_spawn_process. (parse_p12): Likewise, using gnupg_wait_process. * export.c (popen_protect_tool): Ditto. (export_p12): Ditto.
Diffstat (limited to '')
-rw-r--r--sm/gpgsm.c2
1 files changed, 2 insertions, 0 deletions
diff --git a/sm/gpgsm.c b/sm/gpgsm.c
index c96683a46..0feca2608 100644
--- a/sm/gpgsm.c
+++ b/sm/gpgsm.c
@@ -1688,6 +1688,7 @@ open_fwrite (const char *filename)
static void
run_protect_tool (int argc, char **argv)
{
+#ifndef _WIN32
const char *pgm;
char **av;
int i;
@@ -1706,5 +1707,6 @@ run_protect_tool (int argc, char **argv)
av[i] = NULL;
execv (pgm, av);
log_error ("error executing `%s': %s\n", pgm, strerror (errno));
+#endif
gpgsm_exit (2);
}