aboutsummaryrefslogtreecommitdiffstats
path: root/sm/certpath.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2002-05-14 16:51:00 +0000
committerWerner Koch <[email protected]>2002-05-14 16:51:00 +0000
commitc7ceb874c28c0cae77870629f492d61340384944 (patch)
treec01b633e889a6a2b3e32d56bf4a5ccb492602863 /sm/certpath.c
parent* errors.h: Added STARUS_EXPSIG and STATUS_EXPKEYSIG. (diff)
downloadgnupg-c7ceb874c28c0cae77870629f492d61340384944.tar.gz
gnupg-c7ceb874c28c0cae77870629f492d61340384944.zip
sm/
* gpgsm.c: New option --faked-system-time * sign.c (gpgsm_sign): And use it here. * certpath.c (gpgsm_validate_path): Ditto. common/ * gettime.c: New. agent/ * cache.c (housekeeping, agent_put_cache): Use our time() wrapper. / * doc/: New * configure.ac, Makefile.am: Added doc/
Diffstat (limited to 'sm/certpath.c')
-rw-r--r--sm/certpath.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/sm/certpath.c b/sm/certpath.c
index 1283ce46d..28c0be52f 100644
--- a/sm/certpath.c
+++ b/sm/certpath.c
@@ -315,7 +315,7 @@ gpgsm_validate_path (KsbaCert cert, time_t *r_exptime)
char *subject = NULL;
KEYDB_HANDLE kh = keydb_new (0);
KsbaCert subject_cert = NULL, issuer_cert = NULL;
- time_t current_time = time (NULL);
+ time_t current_time = gnupg_get_time ();
time_t exptime = 0;
if (r_exptime)