aboutsummaryrefslogtreecommitdiffstats
path: root/sm/certdump.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-08-26 15:47:22 +0000
committerWerner Koch <[email protected]>2014-08-26 15:47:54 +0000
commit519305feb888b529c005b40445d041a088a2f8fc (patch)
tree74994a5b568e059982ca83a0daa8b7d96035355d /sm/certdump.c
parentgpg: Allow for positional parameters in the passphrase prompt. (diff)
downloadgnupg-519305feb888b529c005b40445d041a088a2f8fc.tar.gz
gnupg-519305feb888b529c005b40445d041a088a2f8fc.zip
Switch to the libgpg-error provided estream.
* configure.ac (NEED_GPG_ERROR_VERSION): Reguire 1.14. (GPGRT_ENABLE_ES_MACROS): Define. (estream_INIT): Remove. * m4/estream.m4: Remove. * common/estream-printf.c, common/estream-printf.h: Remove. * common/estream.c, common/estream.h: Remove. * common/init.c (_init_common_subsystems): Call gpgrt initialization.
Diffstat (limited to '')
-rw-r--r--sm/certdump.c8
1 files changed, 3 insertions, 5 deletions
diff --git a/sm/certdump.c b/sm/certdump.c
index 21a5e292c..23cca7385 100644
--- a/sm/certdump.c
+++ b/sm/certdump.c
@@ -504,9 +504,8 @@ print_dn_part (FILE *fp, estream_t stream,
{
es_fprintf (stream, "/%s=", dn->key);
if (translate)
- es_write_sanitized_utf8_buffer (stream, dn->value,
- strlen (dn->value),
- "/", NULL);
+ print_utf8_buffer3 (stream, dn->value, strlen (dn->value),
+ "/");
else
es_write_sanitized (stream, dn->value, strlen (dn->value),
"/", NULL);
@@ -716,8 +715,7 @@ gpgsm_es_print_name2 (estream_t fp, const char *name, int translate)
if (s2)
{
if (translate)
- es_write_sanitized_utf8_buffer (fp, s + 1, s2 - (char*)s - 1,
- NULL, NULL);
+ print_utf8_buffer (fp, s + 1, s2 - (char*)s - 1);
else
es_write_sanitized (fp, s + 1, s2 - (char*)s - 1, NULL, NULL);
}