aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/conf-riscos/include/config.h
diff options
context:
space:
mode:
authorStefan Bellon <[email protected]>2002-10-28 13:26:44 +0000
committerStefan Bellon <[email protected]>2002-10-28 13:26:44 +0000
commit557f65836d2ad527840db5ecd5550786db55b244 (patch)
tree84b6e6392fb4bf2614614634bc7f2a28fd30e2fb /scripts/conf-riscos/include/config.h
parent* gnupg.spec.in: Use new path for keyserver helpers, /usr/lib is no longer (diff)
downloadgnupg-557f65836d2ad527840db5ecd5550786db55b244.tar.gz
gnupg-557f65836d2ad527840db5ecd5550786db55b244.zip
filetype support for RISC OS
Diffstat (limited to 'scripts/conf-riscos/include/config.h')
-rw-r--r--scripts/conf-riscos/include/config.h24
1 files changed, 14 insertions, 10 deletions
diff --git a/scripts/conf-riscos/include/config.h b/scripts/conf-riscos/include/config.h
index b95bef608..de5609ba2 100644
--- a/scripts/conf-riscos/include/config.h
+++ b/scripts/conf-riscos/include/config.h
@@ -86,6 +86,8 @@
/* Define if your locale.h file contains LC_MESSAGES. */
#define HAVE_LC_MESSAGES 1
+#define LOCALEDIR ""
+
/* Define to 1 if NLS is requested. */
#define ENABLE_NLS 1
@@ -154,7 +156,8 @@
#define SIZEOF_UNSIGNED_LONG 4
/* The number of bytes in a unsigned long long. */
-#define SIZEOF_UNSIGNED_LONG_LONG 0
+/* Is defined later on */
+/* #define SIZEOF_UNSIGNED_LONG_LONG 0 */
/* The number of bytes in a unsigned short. */
#define SIZEOF_UNSIGNED_SHORT 2
@@ -361,29 +364,30 @@
/* define if compiled symbols have a leading underscore */
#define WITH_SYMBOL_UNDERSCORE 1
-#ifdef IS_DEVELOPMENT_VERSION
- #define DEBUG 1
-/* #define M_DEBUG */
- #define M_GUARD 1
-#endif
-
-#define USE_RNDRISCOS 1
-
/* RISC OS specifica */
#if (__CC_NORCROFT == 1) /* Norcroft */
# undef __GNUC__
# define __GNUC_MINOR__ 0
# define __GLIBC__ 0
# define __attribute__(x)
+# define SIZEOF_UNSIGNED_LONG_LONG 0
# if (__CC_NORCROFT_VERSION < 544) /* old version of Norcroft */
# define inline __inline
# define STR(a) #a
# define __func__ "[" __FILE__ ":" STR(__LINE__) "]"
# endif
#else /* gcc */
+# define SIZEOF_UNSIGNED_LONG_LONG 8
#endif
-/* #define USE_EXTERNAL_HKP */
+#define USE_RNDRISCOS 1
+#define HAVE_LDAP_GET_OPTION 1
+
+#ifdef IS_DEVELOPMENT_VERSION
+# define DEBUG 1
+/*# define M_DEBUG */
+# define M_GUARD 1
+#endif
#include "g10defs.h"