aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/autogen.sh
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-26 19:32:44 +0000
committerWerner Koch <[email protected]>2004-10-26 19:32:44 +0000
commit426819244c470baefdcf09af6da03a189e203ab6 (patch)
tree874513fb03b9e1a46aa8f69c47821668ea1e5dc2 /scripts/autogen.sh
parent* configure.ac: New option --disable-gnupg-iconv, define (diff)
downloadgnupg-426819244c470baefdcf09af6da03a189e203ab6.tar.gz
gnupg-426819244c470baefdcf09af6da03a189e203ab6.zip
Detect the Debian mingw32 package.
Diffstat (limited to 'scripts/autogen.sh')
-rwxr-xr-xscripts/autogen.sh40
1 files changed, 25 insertions, 15 deletions
diff --git a/scripts/autogen.sh b/scripts/autogen.sh
index 2ff3c2833..9361ac3f7 100755
--- a/scripts/autogen.sh
+++ b/scripts/autogen.sh
@@ -45,32 +45,42 @@ if test "$1" = "--build-w32"; then
tmp=`dirname $0`
tsdir=`cd "$tmp"; cd ..; pwd`
shift
- host=i386--mingw32
if [ ! -f $tsdir/scripts/config.guess ]; then
echo "$tsdir/scripts/config.guess not found" >&2
exit 1
fi
build=`$tsdir/scripts/config.guess`
-
- if ! mingw32 --version >/dev/null; then
- echo "We need at least version 0.3 of MingW32/CPD" >&2
- exit 1
- fi
+ # See whether we have the Debian cross compiler package or the
+ # old mingw32/cpd system
+ if i586-mingw32msvc-gcc --version >/dev/null 2>&1 ; then
+ host=i586-mingw32msvc
+ crossbindir=/usr/$host/bin
+ conf_CC="CC=${host}-gcc"
+ else
+ host=i386--mingw32
+ if ! mingw32 --version >/dev/null; then
+ echo "We need at least version 0.3 of MingW32/CPD" >&2
+ exit 1
+ fi
+ crossbindir=`mingw32 --install-dir`/bin
+ # Old autoconf version required us to setup the environment
+ # with the proper tool names.
+ CC=`mingw32 --get-path gcc`
+ CPP=`mingw32 --get-path cpp`
+ AR=`mingw32 --get-path ar`
+ RANLIB=`mingw32 --get-path ranlib`
+ export CC CPP AR RANLIB
+ conf_CC=""
+ fi
+
if [ -f "$tsdir/config.log" ]; then
- if ! head $tsdir/config.log | grep i386--mingw32 >/dev/null; then
+ if ! head $tsdir/config.log | grep "$host" >/dev/null; then
echo "Pease run a 'make distclean' first" >&2
exit 1
fi
fi
- crossbindir=`mingw32 --install-dir`/bin
- CC=`mingw32 --get-path gcc`
- CPP=`mingw32 --get-path cpp`
- AR=`mingw32 --get-path ar`
- RANLIB=`mingw32 --get-path ranlib`
- export CC CPP AR RANLIB
-
disable_foo_tests=""
if [ -n "$lib_config_files" ]; then
for i in $lib_config_files; do
@@ -87,7 +97,7 @@ if test "$1" = "--build-w32"; then
fi
[ $DIE = yes ] && exit 1
- $tsdir/configure --build=${build} --host=${host} \
+ $tsdir/configure ${conf_CC} --build=${build} --host=${host} \
${disable_foo_tests} $*
# Ugly hack to overcome a gettext problem. Someone should look into