aboutsummaryrefslogtreecommitdiffstats
path: root/scd/scdaemon.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-04-20 14:17:10 +0000
committerWerner Koch <[email protected]>2004-04-20 14:17:10 +0000
commite950b01ff56c86d8e04b75a7bac4234afc939199 (patch)
treedf584bfcd6ea6348371a037e2983c393c3f02a0d /scd/scdaemon.h
parentInclude jnlib/types.h and remove our own (diff)
downloadgnupg-e950b01ff56c86d8e04b75a7bac4234afc939199.tar.gz
gnupg-e950b01ff56c86d8e04b75a7bac4234afc939199.zip
* pcsc-wrapper.c: New.
* Makefile.am (pkglib_PROGRAMS): Install it here. * apdu.c (writen, readn): New. (open_pcsc_reader, pcsc_send_apdu, close_pcsc_reader): Use the pcsc-wrapper if we are using Pth.
Diffstat (limited to 'scd/scdaemon.h')
-rw-r--r--scd/scdaemon.h2
1 files changed, 2 insertions, 0 deletions
diff --git a/scd/scdaemon.h b/scd/scdaemon.h
index 098738508..1dd32ae90 100644
--- a/scd/scdaemon.h
+++ b/scd/scdaemon.h
@@ -79,6 +79,7 @@ struct app_ctx_s;
struct server_control_s {
struct server_local_s *server_local;
+ int reader_slot; /* Slot of the open reader or -1 if not open. */
struct card_ctx_s *card_ctx;
struct app_ctx_s *app_ctx;
struct {
@@ -101,6 +102,7 @@ void scd_init_default_ctrl (CTRL ctrl);
/*-- command.c --*/
void scd_command_handler (int);
void send_status_info (CTRL ctrl, const char *keyword, ...);
+void scd_update_reader_status_file (void);
/*-- card.c --*/
int card_open (CARD *rcard);