aboutsummaryrefslogtreecommitdiffstats
path: root/scd/scdaemon.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-08-05 09:24:36 +0000
committerWerner Koch <[email protected]>2004-08-05 09:24:36 +0000
commit818e9bad581868f8455a62fb3548b4dcc9d4cbac (patch)
treea42c59abd922f5957105fa0ce880917020fde5f6 /scd/scdaemon.h
parent2004-07-27 Moritz Schulte <[email protected]> (diff)
downloadgnupg-818e9bad581868f8455a62fb3548b4dcc9d4cbac.tar.gz
gnupg-818e9bad581868f8455a62fb3548b4dcc9d4cbac.zip
* configure.ac: Changed tests for libusb to also suuport the
stable version 0.1.x. * scdaemon.texi (Card applications): New section. * scdaemon.c (main): New option --disable-application. * app.c (is_app_allowed): New. (select_application): Use it to check for disabled applications. * ccid-driver.h (CCID_DRIVER_ERR_ABORTED): New. * ccid-driver.c (ccid_open_reader): Support the stable 0.1 version of libusb. (ccid_get_atr): Handle short messages. * apdu.c (my_rapdu_get_status): Implemented.
Diffstat (limited to 'scd/scdaemon.h')
-rw-r--r--scd/scdaemon.h2
1 files changed, 2 insertions, 0 deletions
diff --git a/scd/scdaemon.h b/scd/scdaemon.h
index 1dd32ae90..c8d78c88b 100644
--- a/scd/scdaemon.h
+++ b/scd/scdaemon.h
@@ -52,6 +52,8 @@ struct {
int disable_ccid; /* Disable the use of the internal CCID driver. */
int allow_admin; /* Allow the use of admin commands for certain
cards. */
+ strlist_t disabled_applications; /* card applications we do not
+ want to use. */
} opt;