aboutsummaryrefslogtreecommitdiffstats
path: root/scd/scdaemon.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-08-18 17:34:28 +0000
committerWerner Koch <[email protected]>2003-08-18 17:34:28 +0000
commit0506e4ebec8db4f4b2f5ecdb3122abca8f70b670 (patch)
treedebc0b339fb8fd0c97f9c219eea1dbdf3782f476 /scd/scdaemon.h
parentAdd 'dynload.h' to Makefile.am. (diff)
downloadgnupg-0506e4ebec8db4f4b2f5ecdb3122abca8f70b670.tar.gz
gnupg-0506e4ebec8db4f4b2f5ecdb3122abca8f70b670.zip
* Makefile.am: Add OPENSC_LIBS to all programs.
* scdaemon.c, scdaemon.h: New option --disable-opensc. * card.c (card_open): Implement it. * apdu.c (open_osc_reader, osc_send_apdu): New. (apdu_open_reader) [HAVE_OPENSC]: Use the opensc driver if not disabled. (error_string) [HAVE_OPENSC]: Use sc_strerror. (send_apdu) [HAVE_OPENSC]: Call osc_apdu_send.
Diffstat (limited to 'scd/scdaemon.h')
-rw-r--r--scd/scdaemon.h1
1 files changed, 1 insertions, 0 deletions
diff --git a/scd/scdaemon.h b/scd/scdaemon.h
index bdc4c21b3..20e2fa768 100644
--- a/scd/scdaemon.h
+++ b/scd/scdaemon.h
@@ -54,6 +54,7 @@ struct {
int batch; /* batch mode */
const char *homedir; /* configuration directory name */
const char *ctapi_driver; /* Library to access the ctAPI. */
+ int disable_opensc; /* Disable the sue of the OpenSC framework. */
} opt;