aboutsummaryrefslogtreecommitdiffstats
path: root/scd/scdaemon.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-09-06 13:23:48 +0000
committerWerner Koch <[email protected]>2003-09-06 13:23:48 +0000
commitbe034cf34c3c5bc7787d9b2f8d4c7b6b948d4e2f (patch)
treea35573c9fe82e0b9e5ce804b344a984f901e17ea /scd/scdaemon.c
parent* ccid-driver.c: More work, data can now actually be retrieved. (diff)
downloadgnupg-be034cf34c3c5bc7787d9b2f8d4c7b6b948d4e2f.tar.gz
gnupg-be034cf34c3c5bc7787d9b2f8d4c7b6b948d4e2f.zip
* configure.ac: Required newer versions of some libraries.V1-9-1
* misc.c (openpgp_pk_algo_usage): Allow AUTH where SIGN is allowed. * keygen.c (ask_passphrase): No need to allocated S2K in secure memory. * scdaemon.c (main): --pcsc-driver again defaults to pcsclite. David Corcoran was so kind to remove the GPL incompatible advertisng clause from pcsclite. * apdu.c (apdu_open_reader): Actually make pcsc-driver option work.
Diffstat (limited to 'scd/scdaemon.c')
-rw-r--r--scd/scdaemon.c3
1 files changed, 1 insertions, 2 deletions
diff --git a/scd/scdaemon.c b/scd/scdaemon.c
index fda0bed6f..89be04ab5 100644
--- a/scd/scdaemon.c
+++ b/scd/scdaemon.c
@@ -277,8 +277,7 @@ main (int argc, char **argv )
may_coredump = disable_core_dumps ();
/* Set default options. */
- opt.pcsc_driver = NULL; /* We can't use libpcsclite due to license
- conflicts. */
+ opt.pcsc_driver = "libpcsclite.so";
shell = getenv ("SHELL");