aboutsummaryrefslogtreecommitdiffstats
path: root/scd/scdaemon.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-08-05 09:24:36 +0000
committerWerner Koch <[email protected]>2004-08-05 09:24:36 +0000
commit818e9bad581868f8455a62fb3548b4dcc9d4cbac (patch)
treea42c59abd922f5957105fa0ce880917020fde5f6 /scd/scdaemon.c
parent2004-07-27 Moritz Schulte <[email protected]> (diff)
downloadgnupg-818e9bad581868f8455a62fb3548b4dcc9d4cbac.tar.gz
gnupg-818e9bad581868f8455a62fb3548b4dcc9d4cbac.zip
* configure.ac: Changed tests for libusb to also suuport the
stable version 0.1.x. * scdaemon.texi (Card applications): New section. * scdaemon.c (main): New option --disable-application. * app.c (is_app_allowed): New. (select_application): Use it to check for disabled applications. * ccid-driver.h (CCID_DRIVER_ERR_ABORTED): New. * ccid-driver.c (ccid_open_reader): Support the stable 0.1 version of libusb. (ccid_get_atr): Handle short messages. * apdu.c (my_rapdu_get_status): Implemented.
Diffstat (limited to '')
-rw-r--r--scd/scdaemon.c6
1 files changed, 6 insertions, 0 deletions
diff --git a/scd/scdaemon.c b/scd/scdaemon.c
index f647aecc2..b54a63816 100644
--- a/scd/scdaemon.c
+++ b/scd/scdaemon.c
@@ -80,6 +80,7 @@ enum cmd_and_opt_values
oDisableOpenSC,
oAllowAdmin,
oDenyAdmin,
+ oDisableApplication,
aTest };
@@ -124,6 +125,7 @@ static ARGPARSE_OPTS opts[] = {
/* end --disable-opensc */},
{ oAllowAdmin, "allow-admin", 0, N_("allow the use of admin card commands")},
{ oDenyAdmin, "deny-admin", 0, "@" },
+ { oDisableApplication, "disable-application", 2, "@"},
{0}
};
@@ -493,6 +495,10 @@ main (int argc, char **argv )
case oAllowAdmin: opt.allow_admin = 1; break;
case oDenyAdmin: opt.allow_admin = 0; break;
+ case oDisableApplication:
+ add_to_strlist (&opt.disabled_applications, pargs.r.ret_str);
+ break;
+
default : pargs.err = configfp? 1:2; break;
}
}