aboutsummaryrefslogtreecommitdiffstats
path: root/scd/scdaemon.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-02-24 17:36:11 +0000
committerWerner Koch <[email protected]>2005-02-24 17:36:11 +0000
commit3af261572bdf938f0a2fdde4d9aec82153a7e0e4 (patch)
tree97ea3ee2c40c6a3288182c6e95e92377e3e7a794 /scd/scdaemon.c
parent* command-ssh.c (get_passphrase): Removed. (diff)
downloadgnupg-3af261572bdf938f0a2fdde4d9aec82153a7e0e4.tar.gz
gnupg-3af261572bdf938f0a2fdde4d9aec82153a7e0e4.zip
* gpg-agent.c (handle_connections): Need to check for events if
select returns with -1. * tools.texi (gpg-connect-agent): New. * app-openpgp.c (get_one_do): Never try to get a non cacheable object from the cache. (get_one_do): Add new arg to return an error code. Changed all callers. (do_getattr): Let it return a proper error code. * app.c (select_application): Return an error code and the application context in an new arg. * command.c (open_card): Adjusted for that. Don't use the fallback if no card is present. Return an error if the card has been removed without a reset. (do_reset, cmd_serialno): Clear that error flag. (TEST_CARD_REMOVAL): New. Use it with all command handlers. * scdaemon.c (ticker_thread): Termintate if a shutdown is pending. * apdu.c: Added some PCSC error codes. (pcsc_error_to_sw): New. (reset_pcsc_reader, pcsc_get_status, pcsc_send_apdu) (open_pcsc_reader): Do proper error code mapping. * gpg-connect-agent.c: New. * Makefile.am: Add it.
Diffstat (limited to '')
-rw-r--r--scd/scdaemon.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/scd/scdaemon.c b/scd/scdaemon.c
index 88f393bb1..0fefbd960 100644
--- a/scd/scdaemon.c
+++ b/scd/scdaemon.c
@@ -936,7 +936,7 @@ ticker_thread (void *dummy_arg)
sigs_ev = NULL;
#endif
- for (;;)
+ while (!shutdown_pending)
{
if (!time_ev)
{
@@ -968,6 +968,7 @@ ticker_thread (void *dummy_arg)
}
pth_event_free (sigs_ev, PTH_FREE_ALL);
+ return NULL;
}
#endif /*USE_GNU_PTH*/
#endif /*!HAVE_OPENSC*/