aboutsummaryrefslogtreecommitdiffstats
path: root/scd/pcsc-wrapper.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-07-22 14:16:33 +0000
committerWerner Koch <[email protected]>2014-07-22 14:20:00 +0000
commitbc6b452129178658da7241903ca2174c79281752 (patch)
tree2e026166de8b32518233bf1a55c8eab5ee07d17e /scd/pcsc-wrapper.c
parentgpg: Improve --list-packets output for faulty packets. (diff)
downloadgnupg-bc6b452129178658da7241903ca2174c79281752.tar.gz
gnupg-bc6b452129178658da7241903ca2174c79281752.zip
scd: Do not use the pcsc-wrapper.
* scd/apdu.c (NEED_PCSC_WRAPPER): Do not define. * scd/Makefile.am (libexec_PROGRAMS): Remove gnupg-pcsc-wrapper (gnupg_pcsc_wrapper_SOURCES): Remove. (gnupg_pcsc_wrapper_LDADD): Remove. (gnupg_pcsc_wrapper_CFLAGS): Remove.
Diffstat (limited to 'scd/pcsc-wrapper.c')
-rw-r--r--scd/pcsc-wrapper.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/scd/pcsc-wrapper.c b/scd/pcsc-wrapper.c
index e20e111a9..b3060e115 100644
--- a/scd/pcsc-wrapper.c
+++ b/scd/pcsc-wrapper.c
@@ -20,7 +20,8 @@
/*
This wrapper is required to handle problems with the libpscslite
library. That library assumes that pthreads are used and fails
- badly if one tries to use it with a procerss using Pth.
+ badly if one tries to use it with a process using Pth. Note that
+ the wrapper is not required if nPth is used.
The operation model is pretty simple: It reads requests from stdin
and returns the answer on stdout. There is no direct mapping to the