aboutsummaryrefslogtreecommitdiffstats
path: root/scd/iso7816.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-20 08:54:45 +0000
committerWerner Koch <[email protected]>2004-10-20 08:54:45 +0000
commitd33703e5fe46068ddfe7b04c44ec2e45f1f79ee3 (patch)
tree194a11c2a5fd9138ca8834fd5002a93bd591204c /scd/iso7816.c
parentFixed copyright years (diff)
downloadgnupg-d33703e5fe46068ddfe7b04c44ec2e45f1f79ee3.tar.gz
gnupg-d33703e5fe46068ddfe7b04c44ec2e45f1f79ee3.zip
* sc-investigate: Removed.
* Makefile.am (sc_investigate): Removed. * pcsc-wrapper.c (load_pcsc_driver): Load get_status_change func. (handle_open): Succeed even without a present card. (handle_status, handle_reset): New. * apdu.c (apdu_open_reader): Load pcsc_get_status_change fucntion. (pcsc_get_status): Implemented. (reset_pcsc_reader): Implemented. (open_pcsc_reader): Succeed even with no card inserted. (open_ccid_reader): Set LAST_STATUS. * iso7816.c (iso7816_select_application): Always use 0 for P1.
Diffstat (limited to 'scd/iso7816.c')
-rw-r--r--scd/iso7816.c9
1 files changed, 1 insertions, 8 deletions
diff --git a/scd/iso7816.c b/scd/iso7816.c
index 4861466c1..9eff9d3f7 100644
--- a/scd/iso7816.c
+++ b/scd/iso7816.c
@@ -126,15 +126,8 @@ iso7816_map_sw (int sw)
gpg_error_t
iso7816_select_application (int slot, const char *aid, size_t aidlen)
{
- static char const openpgp_aid[] = { 0xD2, 0x76, 0x00, 0x01, 0x24, 0x01 };
int sw;
- int p1 = 0x0C; /* No FCI to be returned. */
-
- if (aidlen == sizeof openpgp_aid
- && !memcmp (aid, openpgp_aid, sizeof openpgp_aid))
- p1 = 0; /* The current openpgp cards don't allow 0x0c. */
-
- sw = apdu_send_simple (slot, 0x00, CMD_SELECT_FILE, 4, p1, aidlen, aid);
+ sw = apdu_send_simple (slot, 0x00, CMD_SELECT_FILE, 4, 0, aidlen, aid);
return map_sw (sw);
}