aboutsummaryrefslogtreecommitdiffstats
path: root/scd/command.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-03-16 10:49:37 +0000
committerWerner Koch <[email protected]>2004-03-16 10:49:37 +0000
commitf8d44bc637a4c897fd4448de804ee08ae065e194 (patch)
tree03c71726ae3204c67c8dae3fbcdbd4b8c07376a6 /scd/command.c
parent* configure.ac (NEED_GPG_ERROR_VERSION): Set to 0.7. (diff)
downloadgnupg-f8d44bc637a4c897fd4448de804ee08ae065e194.tar.gz
gnupg-f8d44bc637a4c897fd4448de804ee08ae065e194.zip
*** empty log message ***
Diffstat (limited to '')
-rw-r--r--scd/command.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/scd/command.c b/scd/command.c
index d148ddb5a..4746e11b5 100644
--- a/scd/command.c
+++ b/scd/command.c
@@ -351,7 +351,7 @@ cmd_learn (ASSUAN_CONTEXT ctx, char *line)
buf = xtrymalloc (40 + 1 + strlen (certid) + 1);
if (!buf)
- rc = out_of_core ();
+ rc = gpg_error (gpg_err_code_from_errno (errno));
else
{
sprintf (buf, "%d %s", certtype, certid);
@@ -389,7 +389,7 @@ cmd_learn (ASSUAN_CONTEXT ctx, char *line)
buf = p = xtrymalloc (40 + 1 + strlen (keyid) + 1);
if (!buf)
- rc = out_of_core ();
+ rc = gpg_error (gpg_err_code_from_errno (errno));
else
{
int i;
@@ -577,7 +577,7 @@ pin_cb (void *opaque, const char *info, char **retstr)
rc = asprintf (&command, "NEEDPIN %s", info);
if (rc < 0)
- return out_of_core ();
+ return gpg_error (gpg_err_code_from_errno (errno));
/* FIXME: Write an inquire function which returns the result in
secure memory */