aboutsummaryrefslogtreecommitdiffstats
path: root/scd/ccid-driver.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-20 08:54:45 +0000
committerWerner Koch <[email protected]>2004-10-20 08:54:45 +0000
commitd33703e5fe46068ddfe7b04c44ec2e45f1f79ee3 (patch)
tree194a11c2a5fd9138ca8834fd5002a93bd591204c /scd/ccid-driver.c
parentFixed copyright years (diff)
downloadgnupg-d33703e5fe46068ddfe7b04c44ec2e45f1f79ee3.tar.gz
gnupg-d33703e5fe46068ddfe7b04c44ec2e45f1f79ee3.zip
* sc-investigate: Removed.
* Makefile.am (sc_investigate): Removed. * pcsc-wrapper.c (load_pcsc_driver): Load get_status_change func. (handle_open): Succeed even without a present card. (handle_status, handle_reset): New. * apdu.c (apdu_open_reader): Load pcsc_get_status_change fucntion. (pcsc_get_status): Implemented. (reset_pcsc_reader): Implemented. (open_pcsc_reader): Succeed even with no card inserted. (open_ccid_reader): Set LAST_STATUS. * iso7816.c (iso7816_select_application): Always use 0 for P1.
Diffstat (limited to 'scd/ccid-driver.c')
-rw-r--r--scd/ccid-driver.c2
1 files changed, 2 insertions, 0 deletions
diff --git a/scd/ccid-driver.c b/scd/ccid-driver.c
index 0a876f0bc..01c8a9980 100644
--- a/scd/ccid-driver.c
+++ b/scd/ccid-driver.c
@@ -1307,6 +1307,8 @@ ccid_get_atr (ccid_driver_t handle,
/* Note that we ignore the error code on purpose. */
bulk_in (handle, msg, sizeof msg, &msglen, RDR_to_PC_Parameters, seqno);
+ handle->t1_ns = 0;
+ handle->t1_nr = 0;
/* Send an S-Block with our maximun IFSD to the CCID. */
if (!handle->auto_ifsd)