aboutsummaryrefslogtreecommitdiffstats
path: root/scd/app-common.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-07-16 13:47:14 +0000
committerWerner Koch <[email protected]>2003-07-16 13:47:14 +0000
commitfa2faef48f4ed13d7701368ed2332170531e7c1b (patch)
treea4012045d1af575712d35d0e3e0047745556ef79 /scd/app-common.h
parent* simple-pwquery.c, simple-pwquery.h: New; moved from ../agent. (diff)
downloadgnupg-fa2faef48f4ed13d7701368ed2332170531e7c1b.tar.gz
gnupg-fa2faef48f4ed13d7701368ed2332170531e7c1b.zip
* Makefile.am: Add sc-copykeys program.
* sc-copykeys.c: New. * app-openpgp.c (app_openpgp_storekey): New. (app_openpgp_cardinfo): New. (count_bits): New. (store_fpr): And use it here to get the actual length in bit.
Diffstat (limited to '')
-rw-r--r--scd/app-common.h18
1 files changed, 18 insertions, 0 deletions
diff --git a/scd/app-common.h b/scd/app-common.h
index 00d09828c..1527338dd 100644
--- a/scd/app-common.h
+++ b/scd/app-common.h
@@ -83,6 +83,24 @@ int app_genkey (APP app, CTRL ctrl, const char *keynostr, unsigned int flags,
/*-- app-openpgp.c --*/
int app_select_openpgp (APP app, unsigned char **sn, size_t *snlen);
+int app_openpgp_cardinfo (APP app,
+ char **serialno,
+ char **disp_name,
+ char **pubkey_url,
+ unsigned char **fpr1,
+ unsigned char **fpr2,
+ unsigned char **fpr3);
+int app_openpgp_storekey (APP app, int keyno,
+ unsigned char *template, size_t template_len,
+ time_t created_at,
+ const unsigned char *m, size_t mlen,
+ const unsigned char *e, size_t elen,
+ int (*pincb)(void*, const char *, char **),
+ void *pincb_arg);
+int app_openpgp_readkey (APP app, int keyno,
+ unsigned char **m, size_t *mlen,
+ unsigned char **e, size_t *elen);
+
#endif /*GNUPG_SCD_APP_COMMON_H*/