aboutsummaryrefslogtreecommitdiffstats
path: root/scd/apdu.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-07-22 10:52:56 +0000
committerWerner Koch <[email protected]>2004-07-22 10:52:56 +0000
commit44bf2d0ae4adbcf5b6b404bfc6526c461ae6a92a (patch)
tree6f2a43756a965f1c36194b4c91781555ba4701a0 /scd/apdu.c
parent* trustlist.c (read_list): Allow colons in the fingerprint. (diff)
downloadgnupg-44bf2d0ae4adbcf5b6b404bfc6526c461ae6a92a.tar.gz
gnupg-44bf2d0ae4adbcf5b6b404bfc6526c461ae6a92a.zip
* configure.ac: Define AM conditional HAVE_OPENSC.V1-9-10
* Makefile.am: Make OpenSC lib link after libgcrypt. Do not link to pth. * apdu.c: Don't use Pth if we use OpenSC. * sc-investigate.c, scdaemon.c: Disable use of pth if OpenSC is used. * scdaemon.c (main): Bumbed thread stack size up to 512k.
Diffstat (limited to '')
-rw-r--r--scd/apdu.c4
1 files changed, 4 insertions, 0 deletions
diff --git a/scd/apdu.c b/scd/apdu.c
index cc9b213fb..28d32ad2c 100644
--- a/scd/apdu.c
+++ b/scd/apdu.c
@@ -19,6 +19,7 @@
*/
#include <config.h>
+
#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
@@ -31,6 +32,9 @@
#endif
#ifdef HAVE_OPENSC
# include <opensc/opensc.h>
+# ifdef USE_GNU_PTH
+# undef USE_GNU_PTH
+# endif
#endif
/* If requested include the definitions for the remote APDU protocol