aboutsummaryrefslogtreecommitdiffstats
path: root/mpi/mpi-mpow.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-01-12 00:51:39 +0000
committerDavid Shaw <[email protected]>2004-01-12 00:51:39 +0000
commit666c582e36e245af111dbd47f1ae1216bbc1d7bf (patch)
treea1049a31cea43f0848e4f67a8701feba7f0020b4 /mpi/mpi-mpow.c
parentUse the portable C MPI code for OpenBSD before 3.4, and remove the special (diff)
downloadgnupg-666c582e36e245af111dbd47f1ae1216bbc1d7bf.tar.gz
gnupg-666c582e36e245af111dbd47f1ae1216bbc1d7bf.zip
* config.links: OpenBSD 3.4 is now ELF, so use the proper assembler code
for that. Use the portable C MPI code for OpenBSD before 3.4, and remove the special i386-openbsd assembly directory. * Makefile.am: Add the portable C links to DISTCLEANFILES. Noted by Nelson H. F. Beebe. * mpi-mpow.c (build_index): s/index/idx/ to avoid gcc warning. From Werner on stable branch. * longlong.h: Added PowerPC 64 bit code from GPM-4.1.2 but didn't enable it yet. From Werner on stable branch.
Diffstat (limited to '')
-rw-r--r--mpi/mpi-mpow.c10
1 files changed, 4 insertions, 6 deletions
diff --git a/mpi/mpi-mpow.c b/mpi/mpi-mpow.c
index 7c46fc65c..44d8e51fd 100644
--- a/mpi/mpi-mpow.c
+++ b/mpi/mpi-mpow.c
@@ -29,15 +29,15 @@ static int
build_index( MPI *exparray, int k, int i, int t )
{
int j, bitno;
- int index = 0;
+ int idx = 0;
bitno = t-i;
for(j=k-1; j >= 0; j-- ) {
- index <<= 1;
+ idx <<= 1;
if( mpi_test_bit( exparray[j], bitno ) )
- index |= 1;
+ idx |= 1;
}
- return index;
+ return idx;
}
/****************
@@ -97,5 +97,3 @@ mpi_mulpowm( MPI res, MPI *basearray, MPI *exparray, MPI m)
mpi_free(G[i]);
m_free(G);
}
-
-